It is currently Tue Sep 02, 2014 1:22


UT 436 - sound glitches

Need help with one of the installers?
  • Author
  • Message

ivanatora

UT 436 - sound glitches

PostFri Apr 20, 2007 7:44

I have a native installed Unreal Tournament and it plays fine, only the sound is braking up. I run it from a X terminal, so I could see if any error messages show up, but there aren't any.
I have integrated sound chip Intel HDA on motherboard Asrock CONROE945G-DVI. I searched into 'Audio Preferences' of UT but there isn't an option to choose Audio Driver.
How can I run UT in safe mode? I tried ./ut -safe, but nothing `safe` happened.

And here is a part of my UnrealTournament.ini:
Code: Select all
~/.loki/ut/System
AudioDevice=ALAudio.ALAudioSubsystem

[Audio.GenericAudioSubsystem]
UseFilter=True
UseSurround=False
UseStereo=True
UseCDMusic=False
UseDigitalMusic=True
UseSpatial=False
UseReverb=False
Use3dHardware=False
LowSoundQuality=False
ReverseStereo=False
Latency=40
OutputRate=44100Hz
Channels=16
MusicVolume=192
SoundVolume=192
AmbientFactor=0.700000
DopplerSpeed=0.000000

[ALAudio.ALAudioSubsystem]
UseFilter=True
UseSurround=False
UseStereo=True
UseCDMusic=False
UseDigitalMusic=True
UseSpatial=True
UseReverb=True
Use3dHardware=False
LowSoundQuality=False
ReverseStereo=False
Latency=40
OutputRate=22050Hz
Channels=16
MusicVolume=96
SoundVolume=64
AmbientFactor=0.700000
DopplerSpeed=0.000000
MusicBufferSize=16384


Any ideas?
Offline

kratz00

liflg member

  • Posts: 1629
  • Joined: Fri Oct 22, 2004 16:23

PostFri Apr 20, 2007 20:48

Not really, sorry.

Anything interessting in ~/.loki/ut/System/UnrealTournament.log

Maybe try this one: http://www.icculus.org/lgfaq/#utnotesdsnd

ivanatora

PostMon Apr 23, 2007 17:31

Nothing interesting at all in logs.
Code: Select all
Log: Bound to ALAudio.so
Init: OpenAL Audio subsystem initialized.
Init: Game engine initialized
Log: Startup time: 6.447348 seconds.

grep -i sound returns nothing.
Offline

kratz00

liflg member

  • Posts: 1629
  • Joined: Fri Oct 22, 2004 16:23

PostMon Apr 23, 2007 19:36

Did you try the hints from the link I posted?

ivanatora

PostMon Apr 23, 2007 21:27

The first hint was to build OpenAL from source - I did it, but nothing happened.
The second hint was to change this line in the ini file:
AudioDevice=ALAudio.ALAudioSubsystem
with this:
AudioDevice=Audio.GenericAudioSubsystem
The only difference is that the sound plays at higher volume.

Glitching and braking up remains.
I'm not sure, but is there supposed to be 'Choose Audio Driver' in Preferences->Audio? There is no such option here.
Offline

kratz00

liflg member

  • Posts: 1629
  • Joined: Fri Oct 22, 2004 16:23

PostMon Apr 23, 2007 22:34

ivanatora wrote:I'm not sure, but is there supposed to be 'Choose Audio Driver' in Preferences->Audio? There is no such option here.


Nope, i don't see this.

I'm running out of ideas, last idea: play arround with ~/.openalrc

ivanatora

PostTue Apr 24, 2007 18:06

I'm not sure if even ~/.openalrc effects anything, becouse I tried there driver null (it shoud disable all sound) but I still got the same glitching sound.
Offline

kratz00

liflg member

  • Posts: 1629
  • Joined: Fri Oct 22, 2004 16:23

PostTue Apr 24, 2007 20:39

Strange, what does happen if you (re)move libopenal-0.0.so from the 'System' directory.

ivanatora

PostWed Apr 25, 2007 20:11

What happens - nothing o.O
Starting ut... sounds keep glitching.
Er, is it supposed to NOT have a sound at all? :D
Offline

kratz00

liflg member

  • Posts: 1629
  • Joined: Fri Oct 22, 2004 16:23

PostWed Apr 25, 2007 20:33

this was the idea :)

you are now on your own, i'm running out of ideas, sorry

Azzco

PostSun May 20, 2007 16:46

I've got a similar problem, In the Ubuntu forums there was speculations about it being something with the intel chipset or something.
My audio device is:
Intel Corporation 82891H (ICH8 Family) HD Audio Controller (rev 02)

I have no idea how to fix it, but check your audio device and visit this thread in the ubuntuforums.
Offline

kingron

liflg member

  • Posts: 158
  • Joined: Wed Nov 03, 2004 11:14

PostMon May 21, 2007 11:18

please post here your

~/.asoundrc

~/.openalrc

and if exist

~/.openal-speakers

Azzco

PostMon May 21, 2007 16:53

~/.openalrc wrote:(define devices '(alsa sdl artsd))


I don't have any asoundrc nor openal-speakers. Could this maybe be the cause of this problem?

Return to Final

Who is online

Users browsing this forum: No registered users and 1 guest

cron