UT99 e Gdk-WARNING **: locale not supported by C library

Talk about everything.
buby
Posts: 2
Joined: Fri Apr 28, 2017 12:00

UT99 e Gdk-WARNING **: locale not supported by C library

Postby buby » Fri Apr 28, 2017 12:05

Hi there, I am starting to install UT99 on my distro Linux Debian_AMD64 and I have followed this guide and this one.
But after installing the program by running "unreal.tournament_436-multilanguage.run" (spalsh windows ask me to install) I have got this message:

Code: Select all

Uncompressing Unreal Tournament 436-multilanguage Installer...................................................................................
Gtk-WARNING **: Failed to load module "libgail.so": libgail.so: cannot open shared object file: No such file or directory
Gtk-WARNING **: Failed to load module "libatk-bridge.so": libatk-bridge.so: cannot open shared object file: No such file or directory
Gdk-WARNING **: locale not supported by C library
loki_setup: Can't create /home/tito/ut: File exists


But looking and "lacate" these lib I have:

Code: Select all

~$ locate libatk-bridge.so libgail.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libatk-bridge.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libgail.so


At this point I stopped because I dont understand why this is not charged.

Any advice?

Thanks

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: UT99 e Gdk-WARNING **: locale not supported by C library

Postby kratz00 » Fri Apr 28, 2017 18:15

Hi buby

You are running a 64bit system, the installer is looking for 32bit versions of these libraries.


Regards
-Steffen

buby
Posts: 2
Joined: Fri Apr 28, 2017 12:00

Re: UT99 e Gdk-WARNING **: locale not supported by C library

Postby buby » Sat Apr 29, 2017 9:24

Yes, I know, but I did:

Code: Select all

dpkg --add-architecture i386


Code: Select all

sudo dpkg -i libgtk1.2-common_1.2.10-18.1build2_all.deb libglib1.2ldbl_1.2.10-19build1_i386.deb libgtk1.2_1.2.10-18.1build2_i386.deb

and I get these errors:

Code: Select all

   
dpkg: problemi con le dipendenze impediscono la configurazione di libglib1.2ldbl:i386:
libglib1.2ldbl:i386 dipende da libc6 (>= 2.6.1-1).

dpkg: errore nell'elaborare il pacchetto libglib1.2ldbl:i386 (--install):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libgtk1.2:i386:
libgtk1.2:i386 dipende da libc6 (>= 2.7-1).
libgtk1.2:i386 dipende da libglib1.2ldbl (>= 1.2.10-18); comunque:
Il pacchetto libglib1.2ldbl:i386 non è ancora configurato.
libgtk1.2:i386 dipende da libgtk1.2-common (>= 1.2.10-18.1build2); comunque:
libgtk1.2:i386 dipende da libx11-6; comunque:
libgtk1.2:i386 dipende da libxext6; comunque:
libgtk1.2:i386 dipende da libxi6; comunque:

dpkg: errore nell'elaborare il pacchetto libgtk1.2:i386 (--install):
problemi con le dipendenze - lasciato non configurato
Si sono verificati degli errori nell'elaborazione:
libglib1.2ldbl:i386
libgtk1.2:i386


and doesn't work.

At this point I have seen that all it depends from a package named "ia32-libs" that is hard to find out, but searching in (aptitude search ia32libs) there are other 2 packages (lib32z1 lib32ncurses5). The question is if it is necessary to use ia32-libs or instead I can use what aptitude point at.
JUst one curiosity or doubt I have got, could my sources.list not very performing?

Code: Select all

#SECURITY
deb http://security.debian.org/ testing/updates main
deb-src http://security.debian.org/ testing/updates main

# BASE REPOSITORY
deb http://http.us.debian.org/debian/ testing main contrib non-free
deb-src http://http.us.debian.org/debian/ testing main contrib non-free

## Binari per Stretch (testing). Architetture: amd64 armel armhf i386 mips mipsel powerpc
deb http://www.deb-multimedia.org testing main non-free


Thanks for your response
Last edited by buby on Sat Apr 29, 2017 9:58, edited 1 time in total.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: UT99 e Gdk-WARNING **: locale not supported by C library

Postby kratz00 » Sat Apr 29, 2017 9:39

This is not enough, you need to update your package sources (apt-get update) and install the needed 32bit libraries afterwards.

Please read: https://wiki.debian.org/Multiarch/HOWTO ... g_packages


Who is online

Users browsing this forum: No registered users and 2 guests