Page 1 of 1

Tribes 2

Posted: Mon Feb 11, 2013 0:28
by doctoren
So, I managed to get my hands on the Loki port of Tribes 2. Research in the past indicates that it can be difficult to get it to run on modern Linux distributions. However I believe there was some instructions out there that might have helped but now I can't seem to find them. Furthermore there doesn't seem to be much info at this site or at the Loki Compat maintainers site regarding Tribes 2. I seem to recall that you have to do something patch related before installing as the installer will try to use the now obsolete Loki updater but as I said I can't find it at this time.

Starting of slow, I've tried installing it on a 32-bit version of Linux Mint 14. The result so far is

Code: Select all

The setup program seems to have failed on x86/unknown
I believe this might be related to some old glib dependency. Any pointers ?

Re: Tribes 2

Posted: Tue Feb 12, 2013 2:45
by rettichschnidi
Try to use put "linux32" before the command.

Re: Tribes 2

Posted: Tue Feb 12, 2013 18:50
by doctoren
rettichschnidi wrote:Try to use put "linux32" before the command.
Sorry, forgot to mention that I already tried this, but I'm unsure whether this is really needed as I'm not running a 64-bit OS.

The "x86/unknown" seems to indicate the setup cannot determine the glibc version.

I've sort got the game working by copying the cd content and doing the following

Code: Select all

mv setup.sh setupold.sh
sed 's/`DetectLIBC`/"glibc-2.1"/' setupold.sh | sed 's/`DetectARCH`/"x86"/' > setup.sh
chmod +x setup.sh
./setup.sh
It will still give the x86/unknown error but the installer will run. However it does not seem to set the glibc-2.1 as part of the bin/x86/glibc-2.1 path so it will look in the bin/x86 directory. I presume I don't have a suitable glibc version. A workaround was to copy the files in the directory below. Afterwards it was possible to install the game and it will launch. The mouse however is nearly impossible to control and so I didn't manage to actually play the game.

I've found the post I mentioned earlier
http://forums.xandros.com/viewtopic.php ... ff5128a1de

Re: Tribes 2

Posted: Sun Feb 17, 2013 13:52
by kratz00
Have you installed the latest Tribes 2update yet, to resolve the mouse problems you have encountered?

http://lokifiles.tuxgames.com/updates/t ... om-x86.run (this update will patch a basic installation to the latest version)