SuSE 9.2 installation problem

Talk about everything.
Locked
mastergregor

SuSE 9.2 installation problem

Post by mastergregor » Wed Apr 20, 2005 8:42

I am a bit new to Loki and the whole "windows games on linux" concept, and I have run into a problem I can not resolve.

I have tried to "install" two games, and when I try to run either, I get the following:

--------------------------------------------------------------------------------
silvester:/home/gregor/temp # ./nfsu2_1.1-english.us.run
Verifying archive integrity... All good.
Uncompressing Need for Speed:Underground 2 1.1-english.us Installer..........................................................
./nfsu2_1.1-english.us.run: ./setup.sh: /bin/sh: bad interpreter: Permission denied
silvester:/home/gregor/temp #
-------------------------------------------------------------------------------

I tried above command as root and as a regular user with same result. I am not sure what is the problem, but it seams as not a big one.
On RH 9 it works without problems, so I assume SuSE is somehow to blame. Suse is 9.2, fully updated, computer is P4, 1Gb of RAM and nVidia ti4200 w/ 128 MB.

Thanx in advance.

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Apr 20, 2005 9:36


mastergregor

Post by mastergregor » Wed Apr 20, 2005 16:32

Thanks for the reply.

I am not sure what part of the faq do you think I should try. I have tried to run script in new shell (sh ./nfsu2_1.1-english.us.run) and I have tried to run it directly after making it executable. This did not produce any results.

As for the rest of the faq, I do not think any of it applies....

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Apr 20, 2005 17:19

sh ./nfsu2_1.1-english.us.run

whats the problem?

mastergregor

Post by mastergregor » Wed Apr 20, 2005 21:41

Kratz00,
I have tried that, and what I get is the same as if I do not start it with another shell:
--------------------------------------------------------------------------------
silvester:/home/gregor/temp # sh ./nfsu2_1.1-english.us.run
Verifying archive integrity... All good.
Uncompressing Need for Speed:Underground 2 1.1-english.us Installer..........................................................
./nfsu2_1.1-english.us.run: ./setup.sh: /bin/sh: bad interpreter: Permission denied
silvester:/home/gregor/temp #
--------------------------------------------------------------------------------

Again, since it worked on RedHat 9, I do assume that this is actually SuSE 9.2 problem, but I am not sure what is going on, or how to remedy the situation.

Thanx in advance.

schoki

Post by schoki » Wed Apr 20, 2005 22:05

hmm,

Code: Select all

./nfsu2_1.1-english.us.run: ./setup.sh: /bin/sh: bad interpreter: Permission denied 
check you permissions for /bin/sh

mastergregor

Post by mastergregor » Thu Apr 21, 2005 2:41

Schoki,
Thanks for a reply. I have checked the permissions and they seam OK. Here is the result:

----------------------------------------------------------------------
silvester:/home/gregor/temp # ls -al /bin/sh
lrwxrwxrwx 1 root root 4 2005-03-20 15:37 /bin/sh -> bash
silvester:/home/gregor/temp # ls -al /bin/bash
-rwxr-xr-x 1 root root 480744 2004-12-03 12:32 /bin/bash
silvester:/home/gregor/temp #
--------------------------------------------------------------

The thing that bothers me the most is that things work on RH9 whithout even a glitch.

Is there some debugging thing I can run, like "set -x" or something simmilar?

Thanks in advance guys.

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Thu Apr 21, 2005 10:00

i think the problem is your hd is mounted with noexec flag

you could extract the installer with --keep
change in the new created directory and run sh ./setup.sh

Guest

Post by Guest » Thu Apr 21, 2005 14:45

kratz00,
you could be totaly right. I do have /tmp mounted in RAM and as noexec and if installer is trying to unpack and run from there ....... It could mean that my noexec security scam is actaully working.
I'll look into this as soon as I get home and I'll let you know what's going on.

mastergregor

Post by mastergregor » Mon Apr 25, 2005 7:21

Kratz00,
the problem is solved and you were 100% right! The problem was that I mounted /tmp to RAM and used noexec flag. Once I removed the noexec from mounting, it runs just fine.

Thanks a lot for helpping out!

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Apr 27, 2005 12:00

no problem, you are welcome!

Locked