Slowing down native Linux games

Talk about everything.
Post Reply
nilux

Slowing down native Linux games

Post by nilux » Sat Feb 10, 2007 1:43

Hi there, I am looking for a way to slow down my old Linux Games (Serious Sam, Unreal Tournament), because they run way too fast! Is there an equivalent to wine's '-cpuspeed=x' parameter?

nilux

Post by nilux » Sun Feb 11, 2007 17:49

I've found a workaround; on my Ubuntu 6.10 i use the cpufreq-selector command which works this way :
sudo cpufreq-selector -f (frequency in kHz, which means that if you want 2GHz, you'll type 2000000)
And then i launch my game.
When you reboot your computer, this setting is reset to your CPU default :)

voOosh

Post by voOosh » Wed Apr 11, 2007 5:43

Does anybody know why this happens?

I experience the same speed up issues in Serious Sam, Unreal Tournament, and TaticalOps:AoT.

It looks I'm performing a timedemo on meth when I play.

Is there an alternative to the cpufreq-selector hack?

System specs if it helps:
Fedora 6 ABit AN8 32X AMD64 4000 single core 2.6.20-1.2933.fc6 #1 SMP i686 athlon i386 GNU/Linux

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Apr 11, 2007 18:35

http://www.icculus.org/lgfaq/#runeutfast

the scripts stress the cpu for 4 seconds, so it's running at it's maximum before the game is started, give it a try.

Post Reply