Many installers fail with Ubuntu 10.10 32bit

Need help with one of the installers?
ripper
Posts: 18
Joined: Sun Apr 18, 2010 14:01

Many installers fail with Ubuntu 10.10 32bit

Postby ripper » Thu Oct 28, 2010 13:58

Many of liflg installers fail to run on Ubuntu 10.10 32bit (and some other distros as well, e.g. Arch Linux). On 64bit version it runs fine. Example:

Code: Select all

kamil@maverick:~$ ./doom3_1.3.1.1304-multilanguage.run
Verifying archive integrity... All good.
Uncompressing DOOM III 1.3.1.1304-multilanguage Installer................................................................
kamil@maverick:~$


Simply put - nothing happens, installer dies after uncompressing phase.

But if you downgrade libxml2 from 2.7.7.dfsg-4 (available in Ubuntu 10.10) to 2.7.6.dfsg-1ubuntu1 (available in Ubuntu 10.04), everything runs fine.

I have tried all the installers from Final section, these are affected:
    doom3
    kingpin
    nwn
    racer
    serious sam
    serious sam 2
    ut2004


There are probably some more affected installers from Beta section.

Once again I'll say that this only concerns 32bit system, not 64bit one.

Any chance of fixing this soon?

Thanks.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Thu Oct 28, 2010 18:59

Hi ripper,

thanks for the heads-up.

Do you no what has changed between those two libxml2 versions?
Maybe it's a bug in the newer package, if not:

Will we fix them? Yes, of course.
Will it happen soon? Probably not.

ripper
Posts: 18
Joined: Sun Apr 18, 2010 14:01

Postby ripper » Thu Oct 28, 2010 22:39

Well the changelog is here, if you can read something out of it:
http://changelogs.ubuntu.com/changelogs ... /changelog

I can gladly help you report a bug against Ubuntu's libxml2 on Launchpad if you discover that it is really a fault in that package. Unfortunately I don't know much about your installer, so I don't really know whether your or their code triggers that problem. But I hope you will be able to decide after you examine it.

Thanks in advance.

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Postby rettichschnidi » Thu Nov 25, 2010 0:58

Short update: We tracked down the problem to the fact, that we link statically to the zlib and dynamically to the libxml, which in turn again links dynamically to the zlib.

As it seems the effect is that we have some zlib functions/symbols defined twice at runtime, both from another zlib version. Since there are some changes (apply mainly to x86 builds) between zlib-1.2.3 (used by our build-server) and recent versions, the Installer fails on x86. I'm not yet sure why exactly this error happens, but we have a working solution: link zlib dynamically to our installer.

We will start to update the installers hopefully this weekend. However, some of the installers should be converted directly to Mojosetup which wont happen this weekend for sure.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Wed Dec 29, 2010 18:49

We started converting installers, first up is Racer:

http://liflg.org/?catid=7&gameid=13

ben51
Posts: 3
Joined: Sun Jan 02, 2011 20:05

Postby ben51 » Sun Jan 02, 2011 20:38

Hello,

ripper wrote: On 64bit version it runs fine.


On my Fedora 64-bit I encounter the same problem as you.

kratz00 wrote:We started converting installers, first up is Racer:

http://liflg.org/?catid=7&gameid=13

I tested and it works well.

I have just this error.

Code: Select all

(<unknown>: 22550): Gtk-WARNING **: Could not Find the theme engine in module_path: "clearlooks"


But it does not block the execution, just as the window is not decorated.
Yet the theme clearslooks installed on my system :/


Thanks ;)

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Sun Jan 02, 2011 21:26

Hi ben51,

thanks your feedback.

This GTK error you get, it's only a warning :)
Do you get this message with other GTK applications?

ben51
Posts: 3
Joined: Sun Jan 02, 2011 20:05

Postby ben51 » Mon Jan 03, 2011 23:35

kratz00 wrote:Hi ben51,

thanks your feedback.

This GTK error you get, it's only a warning :)
Do you get this message with other GTK applications?

Only programs loki :/

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Tue Jan 04, 2011 15:01

Hi ben51,

as I wrote, it's only a warning but you can fix this if you want.

Problem is:
- your os is 64bit
- installer is 32bit and requires 32bit gtk2
- you need to install gtk-engines for 32bit

And then everything should look fine :)

ben51
Posts: 3
Joined: Sun Jan 02, 2011 20:05

Re: Many installers fail with Ubuntu 10.10 32bit

Postby ben51 » Sun Jan 23, 2011 23:41

kratz00 wrote:Hi ben51,

as I wrote, it's only a warning but you can fix this if you want.


Problem is:

- your os is 64bit

- installer is 32bit and requires 32bit gtk2

- you need to install gtk-engines for 32bit

And then everything should look fine :)

Thank you,

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Many installers fail with Ubuntu 10.10 32bit

Postby kratz00 » Mon Jan 24, 2011 22:14

Hi ben51,

did you test it?
Does it work for you?

pradhishkumar
Posts: 6
Joined: Mon May 31, 2010 13:43

Re: Many installers fail with Ubuntu 10.10 32bit

Postby pradhishkumar » Tue Mar 08, 2011 4:49

for peopel who want a quick fix. just download this file and install it with

http://archive.ubuntu.com/ubuntu/pool/m ... 1_i386.deb

sudo dpkg -i '/"location"/libxml2_2.7.6.dfsg-1ubuntu1_i386.deb'

this will automatically downgrade it to the required verison u can upgrade after u complete the installation.

happy gaming

seanj
Posts: 1
Joined: Tue Apr 19, 2011 20:21

Re: Many installers fail with Ubuntu 10.10 32bit

Postby seanj » Tue Apr 19, 2011 20:23

I tried the quick fix, but when running the ut2004 installer, after entering the cd key and pressing next, the installer freezes, there's no activity on the dvd drive, and no output to the terminal.


Who is online

Users browsing this forum: No registered users and 1 guest