Serious Sam TFE & TSE won't start

Need help with one of the installers?
rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Serious Sam TFE & TSE won't start

Postby rettichschnidi » Sat Feb 05, 2011 12:05

I can offer you to use this one: http://files.reto-schneider.ch/diesundd ... fe-cpuburn (change GAME_BINARY if you need)

Unfortunately it's not yet tested excessively, but someday we'll include something like this for all games that have problems with frequence-scaling cpu's.
Last edited by rettichschnidi on Fri Feb 28, 2014 23:22, edited 1 time in total.
Reason: ftp->http

Kakarott
Posts: 10
Joined: Wed Jan 19, 2011 11:24

Re: Serious Sam TFE & TSE won't start

Postby Kakarott » Sat Feb 05, 2011 14:26

That's how I like it :D

BIG Thanks !!

PS: I didn't try The Second Encounter yet but there is likely to be something like the same issue. Do you have the binary ready for it? Or should I ask back when I am ready to play ? ^^

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Serious Sam TFE & TSE won't start

Postby rettichschnidi » Sat Feb 05, 2011 16:22

Since it is just a single bit to flip :) : http://files.reto-schneider.ch/diesundd ... ix-ssamtse
Last edited by rettichschnidi on Thu Feb 27, 2014 9:13, edited 1 time in total.
Reason: ftp->http

FTL
Posts: 13
Joined: Fri Apr 02, 2010 19:42

Re: Serious Sam TFE & TSE won't start

Postby FTL » Thu Apr 21, 2011 19:15

Would it be possible to fix those two links for the "CPU scaling fix" binaries?
I got both Sams running, but have the same issue, as Kakarott had and those links seem to be dead.
Thank you.

Kakarott
Posts: 10
Joined: Wed Jan 19, 2011 11:24

Re: Serious Sam TFE & TSE won't start

Postby Kakarott » Thu Apr 21, 2011 19:52

FTL wrote:Would it be possible to fix those two links for the "CPU scaling fix" binaries?
I got both Sams running, but have the same issue, as Kakarott had and those links seem to be dead.
Thank you.


I put them here:
http://code.google.com/p/manuel-bellers ... loads/list
Should be ready in a second.

FTL
Posts: 13
Joined: Fri Apr 02, 2010 19:42

Re: Serious Sam TFE & TSE won't start

Postby FTL » Thu Apr 21, 2011 22:12

Thank you so much, now it behaves correctly. :)

I haven't spent so much time with it, but so far, both FE and SE played just fine and with highest possible settings it still looks cool, cool as I remember. Well, back then I really couldn't afford 16x aniso..

Just two minor things I noticed:

#1
I was using the HD gold edition version, which basically is a re-edition that includes FE, FE:HD, SE and SE:HD.
The installer can't be used with this edition, so I unpacked the loki installer files, did an install of both FE and SE in wine. Everything seems to be fine, but no music. If it was using MIDI, I would understand that, but I think Sam doesn't. In-game sound is working normally in both games.

#2
With TSE installer unpacked, the bins.tar.bz2 contains libEntitiesMP.so and libGameMP.so, which none of the linux binaries seem to be looking for, but instead they are looking for libEntities.so and libGame.so, which are not present, so it crashes.
But I noticed, that TFE installer doesn't have libEntitiesMP.so and libGameMP.so, only the 'non-MP' variants. OK, so I renamed TSE installer's MPs to non-MPs, works now. I wonder why is here this inconsistency and if just the renaming can have some side effects. :)

But generally, it works beautifully. Thanks a lot. :)

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Serious Sam TFE & TSE won't start

Postby rettichschnidi » Fri Jun 03, 2011 23:11

@SS HD: please post to layout of the disc here:

Code: Select all

find . -type f -exec file "{}" \;


@Bugs: I added this to our bugtracker.

doctoren
liflg beta tester
Posts: 27
Joined: Sat May 07, 2011 11:04

Re: Serious Sam TFE & TSE won't start

Postby doctoren » Wed Jun 22, 2011 9:34

This counts for both installers. They will uncompress and then quit back to the terminal without any error and it doesn't seem like anything was extracted or else it was instantly deleted. System is Ubuntu 11.04 32-bit.

Moose
Posts: 3
Joined: Sun Aug 14, 2011 14:45

Re: Serious Sam TFE & TSE won't start

Postby Moose » Sun Aug 14, 2011 15:05

I kind of having the same problem
Sofar i have only installed SSFE install went fine (with some modifications) from this site : http://half-a-page.blogspot.com/2010/10/serious-sam-first-encounter-on-ubuntu.html

But when i try to start the game all i get is a black screen with my cursor on the upper left corner, and then the computer goes "ded" and i have to turn it off completly.. any ideas..

Moose
Posts: 3
Joined: Sun Aug 14, 2011 14:45

Re: Serious Sam TFE & TSE won't start

Postby Moose » Wed Aug 17, 2011 14:58

Bump

I tried all the solutions mentioned in this thread but still no luck...

Cant anybody help please

Moose
Posts: 3
Joined: Sun Aug 14, 2011 14:45

Re: Serious Sam TFE & TSE won't start

Postby Moose » Fri Aug 19, 2011 19:34

Is this site no longer maintained if no... why dont you guys just pull the off switch ???????????

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Serious Sam TFE & TSE won't start

Postby rettichschnidi » Sat Aug 20, 2011 6:30

LIFLG is not dead, we just all have a real life which sometimes takes its share.

As you did not deliver any usefull information (Hardware, Driver, Distribution, console output, etc.) I decided to answer when I got more time. If you can deliver this information, I'll reply hopefully in two weeks (maybe someone else is faster).

lats_fro
Posts: 1
Joined: Fri Feb 07, 2014 2:36

Re: Serious Sam TFE & TSE won't start

Postby lats_fro » Tue Feb 25, 2014 20:38

Hi kratz00

I have been trying to play Serious Sam TFE but I think I have a similar problem to the one in this thread. The install seems to work fine using the installer but executing the program I get the following without the game loading :

$ ./ssam_lnx.dynamic
STUB: load window icon in SeriousSam/MainWindow.cpp, line 153.
STUB: Need SDL invisible window or something in SeriousSam/MainWindow.cpp, line 356.
INFO: "SeriousSam is starting for the first time.
If you experience any problems, please consult
ReadMe file for troubleshooting information."
Segmentation fault (core dumped)

or

$sudo ./ssam_lnx.dynamic
STUB: load window icon in SeriousSam/MainWindow.cpp, line 153.
STUB: Need SDL invisible window or something in SeriousSam/MainWindow.cpp, line 356.
INFO: "SeriousSam is starting for the first time.
If you experience any problems, please consult
ReadMe file for troubleshooting information."

Here are some of my system specs

$ uname -a
Linux craig-VGN-FW30B 3.11.0-15-generic #25-Ubuntu SMP Thu Jan 30 17:25:07 UTC 2014 i686 i686 i686 GNU/Linux

Also I have an ATI HD3470 graphics card and am using the open source Radeon drivers from the oibaf ppa.

$ glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Gallium 0.4 on AMD RV620
GL_MESA_texture_signed_rgba, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp,

$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k3.11.0-15-generic.



I compared my files against the listing that Kakarott listed and found the following discrepencies:

2d510ef58aa1769624aa9be43131e0aa ./.manifest/scripts/update-menus-0.sh (File does not exist after install)

85afc78c70e043e99cb9e1dc22f85f71 ./.manifest/ssamtfe.xml
81dd27289bba8f9e0daa48de1f24ff05 ./.manifest/ssamtfe.xml
95276103d833587ac78146c84397de18 ./uninstall
6d732e37e9f4bf44fda458c06ecbd50d ./uninstall

I checked all the dependencies from the readme file and according to synaptic I have them installed.

I checked the 32bit GL as well

$ find /usr/lib* -name "*libGL*"
/usr/lib/libGLEW.so.1.5.2
/usr/lib/i386-linux-gnu/libGLU.so
/usr/lib/i386-linux-gnu/libGLEWmx.so.1.8.0
/usr/lib/i386-linux-gnu/libGLEW.so.1.8.0
/usr/lib/i386-linux-gnu/libGL.so
/usr/lib/i386-linux-gnu/libGLEWmx.so.1.8
/usr/lib/i386-linux-gnu/libGLU.so.1.3.1
/usr/lib/i386-linux-gnu/libGLU.so.1
/usr/lib/i386-linux-gnu/libGLEW.so.1.8
/usr/lib/i386-linux-gnu/libGLU.a
/usr/lib/i386-linux-gnu/mesa/libGL.so.1
/usr/lib/i386-linux-gnu/mesa/libGL.so.1.2.0
/usr/lib/i386-linux-gnu/mesa/libGL.so
/usr/lib/libGLEW.so.1.5

I tried to run the game from the installed 'ssam_lnx.dynamic' file and also the 'fix' copy that was linked from this thread.
I tried using the strace but the results are a bit beyond my knowlegde.

Also, TSE has the exact same results as TFE. But I managed to install and play Serious Sam 2.

I feel like my issue may be related to the one posted here. Please let me know what you think any help would be great, I would really like to play this game on linux.

Thanks

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Serious Sam TFE & TSE won't start

Postby rettichschnidi » Thu Feb 27, 2014 9:20

lats_fro wrote:I have been trying to play Serious Sam TFE but I think I have a similar problem to the one in this thread.

...
lats_fro wrote:Also I have an ATI HD3470 graphics card and am using the open source Radeon drivers from the oibaf ppa.


The original problem existed for the binary driver. I have no idea if it applies to the opensource driver as well. I will test it on my old HD4670 when I have time. If you do not get an answer in time, pls bump this thread again.

lats_fro wrote:I tried to run the game from the installed 'ssam_lnx.dynamic' file and also the 'fix' copy that was linked from this thread.


How did you do that? The server was dead for like one year and i just got it up and running again this morning.

lats_fro wrote:I feel like my issue may be related to the one posted here. Please let me know what you think any help would be great, I would really like to play this game on linux.


Give us some time but bump the thread whenever you think we have forgotten about you and we might get it running. :wink:


Who is online

Users browsing this forum: No registered users and 4 guests