Kingpin does not work on Ubuntu 14.04

Need help with one of the installers?
mat
Posts: 65
Joined: Mon Oct 10, 2005 18:10

Kingpin does not work on Ubuntu 14.04

Postby mat » Tue Aug 18, 2015 18:42

Hi

I tried to run Kingpin on Ubuntu 14.04 but it does not work:

./kingpin.sh +set gl_mode 3
KPHack 0.0.5: DGA mouse enabled; FullScreen enabled.
Added packfile ./main/pak0.pak (456 files)
execing default.cfg
couldn't exec config.cfg
couldn't exec linux.cfg
Console initialized.

------- sound initialization -------
/dev/dsp: Input/output error
Could not open /dev/dsp
------- Loading ref_glx.so -------
ref_gl version: GL 0.01
R_SetMode() - CDS not allowed with this driver
Initializing OpenGL display
...setting mode 3: 1024 768
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 320M/integrated/SSE2
GL_VERSION: 3.3.0 NVIDIA 340.76
GL_EXTENSIONS: GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_clear_buffer_object GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_include GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback_instanced GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2 GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_x11_sync_object GL_EXT_import_sync_object GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KHR_debug GL_KTX_buffer_region GL_NV_blend_square GL_NV_conditional_render GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_depth_clamp GL_NV_ES1_1_compatibility GL_NV_explicit_multisample GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_gpu_program4_1 GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_parameter_buffer_object2 GL_NV_path_rendering GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_shader_buffer_load GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_multisample GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_transform_feedback2 GL_NV_vdpau_interop GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_NVX_gpu_memory_info GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
Received signal 11, exiting...

I tried to use this script because it worked previously, but now I have some issues with it:

viewtopic.php?f=2&t=969&p=5497&hilit=kingpin#p5497

./kingpin
KPHack 0.0.5: DGA mouse enabled; FullScreen enabled.
Added packfile ./main/pak0.pak (456 files)
execing default.cfg
couldn't exec config.cfg
couldn't exec linux.cfg
Console initialized.

------- sound initialization -------
/dev/dsp: Input/output error
Could not open /dev/dsp
------- Loading ref_glx.so -------
ref_gl version: GL 0.01
R_SetMode() - CDS not allowed with this driver
Initializing OpenGL display
...setting mode 0: 640 480
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 45
Current serial number in output stream: 46

Can you help me?

uname -a
Linux ******-Macmini 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24 21:18:00 UTC 2015 i686 i686 i686 GNU/Linux

This is my computer:

https://support.apple.com/kb/SP586?locale=en_US

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Kingpin does not work on Ubuntu 14.04

Postby kratz00 » Tue Aug 18, 2015 20:52

Hi mat

Our startscript is fine.
The crash is most probably related to http://wiki.linuxgaming.de/index.php/Ki ... ber_zu_neu
Please give it a try and report back.


Regards
-Steffen

mat
Posts: 65
Joined: Mon Oct 10, 2005 18:10

Re: Kingpin does not work on Ubuntu 14.04

Postby mat » Tue Aug 18, 2015 22:25

kratz00 wrote:Hi mat

Our startscript is fine.
The crash is most probably related to http://wiki.linuxgaming.de/index.php/Ki ... ber_zu_neu
Please give it a try and report back.


Regards
-Steffen


Thank you.

I modified the file ref_glx, and now it works.

Unfortunately, I do not have the sound in the game, and I tried different methods:

padsp ./kingpin.sh
KPHack 0.0.5: DGA mouse enabled; FullScreen enabled.
Added packfile ./main/pak0.pak (456 files)
execing default.cfg
execing config.cfg
couldn't exec linux.cfg
Console initialized.

------- sound initialization -------
Sorry but your soundcard can't do this

------- Loading ref_glx.so -------
ref_gl version: GL 0.01
R_SetMode() - CDS not allowed with this driver
Initializing OpenGL display
...setting mode 0: 640 480
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 320M/integrated/SSE2
GL_VERSION: 3.3.0 NVIDIA 304.125
GL_EXTENSIONS:
...allowing CDS
------------------------------------
execing autoexec.cfg
------- Loading gamei386.so -------
==== InitGame ====
------- Server Initialization -------
0 entities inhibited
0 teams with 0 entities
0 special teams
-------------------------------------
====== Kingpin Initialized ======

0.0.0.0:0: client_connect
==== ShutdownGame ====
Received signal 11, exiting...

aoss ./kingpin.sh
KPHack 0.0.5: DGA mouse enabled; FullScreen enabled.
Added packfile ./main/pak0.pak (456 files)
execing default.cfg
execing config.cfg
couldn't exec linux.cfg
Console initialized.

------- sound initialization -------
sound sampling rate: 11025
Segmentation fault (core dumped)


"echo 'kingpin.x86 0 0 direct' > /proc/asound/card0/pcm0p/oss"
bash: echo 'kingpin.x86 0 0 direct' > /proc/asound/card0/pcm0p/oss: No such file or directory

Can you help me?

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Kingpin does not work on Ubuntu 14.04

Postby kratz00 » Tue Aug 18, 2015 22:33

Does

Code: Select all

sudo apt-get install alsa-oss

help?

mat
Posts: 65
Joined: Mon Oct 10, 2005 18:10

Re: Kingpin does not work on Ubuntu 14.04

Postby mat » Tue Aug 18, 2015 22:54

kratz00 wrote:Does

Code: Select all

sudo apt-get install alsa-oss

help?


No. I installed this package but I do not have sound in this game:


sudo apt-get install alsa-oss
[sudo] password for gbudny:
Reading package lists... Done
Building dependency tree
Reading state information... Done
alsa-oss is already the newest version.
The following packages were automatically installed and are no longer required:
bbswitch-dkms linux-headers-generic-lts-vivid linux-image-generic-lts-vivid
nvidia-prime thermald
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

./kingpin.sh
KPHack 0.0.5: DGA mouse enabled; FullScreen enabled.
Added packfile ./main/pak0.pak (456 files)
execing default.cfg
execing config.cfg
couldn't exec linux.cfg
Console initialized.

------- sound initialization -------
Sorry but your soundcard can't do this

------- Loading ref_glx.so -------
ref_gl version: GL 0.01
R_SetMode() - CDS not allowed with this driver
Initializing OpenGL display
...setting mode 0: 640 480
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 320M/integrated/SSE2
GL_VERSION: 3.3.0 NVIDIA 304.125
GL_EXTENSIONS:
...allowing CDS
------------------------------------
execing autoexec.cfg
------- Loading gamei386.so -------
==== InitGame ====
------- Server Initialization -------
0 entities inhibited
0 teams with 0 entities
0 special teams
-------------------------------------
====== Kingpin Initialized ======

0.0.0.0:0: client_connect
==== ShutdownGame ====
KPHack 0.0.5: Cleaning up.
recursive shutdown

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Kingpin does not work on Ubuntu 14.04

Postby kratz00 » Wed Aug 19, 2015 7:40

If you do not have a /proc/asound/card0/pcm0p/oss device something has to be wrong with your Alsa OSS setup.
Or maybe pulseaudio is blocking the device.
After that works, the echo command should do the trick.

mat
Posts: 65
Joined: Mon Oct 10, 2005 18:10

Re: Kingpin does not work on Ubuntu 14.04

Postby mat » Wed Aug 19, 2015 14:20

kratz00 wrote:If you do not have a /proc/asound/card0/pcm0p/oss device something has to be wrong with your Alsa OSS setup.
Or maybe pulseaudio is blocking the device.
After that works, the echo command should do the trick.


I checked this directory, and I did not find the file oss:

pwd
/proc/asound/card0/pcm0p

ls
info sub0

I found the directory oss in this location:

ls
card0 cards devices hwdep modules NVidia oss pcm seq timers version

pwd
/proc/asound

Unfortunately, I have problem with this command:

"echo 'kingpin.x86 0 0 direct' > /proc/asound/oss"
bash: echo 'kingpin.x86 0 0 direct' > /proc/asound/oss: No such file or directory

I remember that sometimes in the classic games for Linux there was a problem with the missing /dev/dsp:

ls
adsp loop4 random tty19 tty52 ttyS27
autofs loop5 rfkill tty2 tty53 ttyS28
block loop6 rtc tty20 tty54 ttyS29
bsg loop7 rtc0 tty21 tty55 ttyS3
btrfs-control loop-control sda tty22 tty56 ttyS30
bus mapper sda1 tty23 tty57 ttyS31
char mcelog sda2 tty24 tty58 ttyS4
console mem sda3 tty25 tty59 ttyS5
core memory_bandwidth sda4 tty26 tty6 ttyS6
cpu mixer sda5 tty27 tty60 ttyS7
cpu_dma_latency net sda6 tty28 tty61 ttyS8
cuse network_latency sda7 tty29 tty62 ttyS9
disk network_throughput sda8 tty3 tty63 uhid
dri null sda9 tty30 tty7 uinput
dsp nvidia0 sdb tty31 tty8 urandom
ecryptfs nvidiactl sdb1 tty32 tty9 usb
fd port sdb2 tty33 ttyprintk vcs
full ppp sg0 tty34 ttyS0 vcs1
fuse psaux sg1 tty35 ttyS1 vcs2
fw0 ptmx shm tty36 ttyS10 vcs3
hidraw0 pts snapshot tty37 ttyS11 vcs4
hidraw1 ram0 snd tty38 ttyS12 vcs5
hidraw2 ram1 stderr tty39 ttyS13 vcs6
hidraw5 ram10 stdin tty4 ttyS14 vcs7
hpet ram11 stdout tty40 ttyS15 vcsa
i2c-0 ram12 tty tty41 ttyS16 vcsa1
i2c-1 ram13 tty0 tty42 ttyS17 vcsa2
i2c-2 ram14 tty1 tty43 ttyS18 vcsa3
i2c-3 ram15 tty10 tty44 ttyS19 vcsa4
input ram2 tty11 tty45 ttyS2 vcsa5
kmsg ram3 tty12 tty46 ttyS20 vcsa6
kvm ram4 tty13 tty47 ttyS21 vcsa7
log ram5 tty14 tty48 ttyS22 vfio
loop0 ram6 tty15 tty49 ttyS23 vga_arbiter
loop1 ram7 tty16 tty5 ttyS24 vhci
loop2 ram8 tty17 tty50 ttyS25 vhost-net
loop3 ram9 tty18 tty51 ttyS26 zero

Unfortunately, I have this file, and sound doesn't work in kingpin

I also tried to install osspd-alsa but it did not help in this case.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Kingpin does not work on Ubuntu 14.04

Postby kratz00 » Wed Aug 19, 2015 14:44

If /proc/asound/card0/pcm0p/ossdoes not exist, then you need to load the following kernel module first:

Code: Select all

sudo modprobe snd-pcm-oss

mat
Posts: 65
Joined: Mon Oct 10, 2005 18:10

Re: Kingpin does not work on Ubuntu 14.04

Postby mat » Wed Aug 19, 2015 15:19

kratz00 wrote:If /proc/asound/card0/pcm0p/ossdoes not exist, then you need to load the following kernel module first:

Code: Select all

sudo modprobe snd-pcm-oss


Thank you.

This command works.

Do you plan to add the modified version of the file ref_glx.so into the new version of your installer?

I noticed some projects like et-sdl-sound or your script for the game Sin. Do you think it will be possible to modify them and prepare the special version for Kingpin. Perhaps, this procedure of the loading kernel module snd-pcm-oss won't be needed in the case of kingpin for Linux.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Kingpin does not work on Ubuntu 14.04

Postby kratz00 » Wed Aug 19, 2015 15:46

I am a little confused.

Does Kingpin work now (with sound)?
Do you need the echo 'kingpin.x86 0 0 direct' > /proc/asound/oss trick?

mat wrote:Do you plan to add the modified version of the file ref_glx.so into the new version of your installer?


No plans at the moment.

mat wrote:I noticed some projects like et-sdl-sound or your script for the game Sin. Do you think it will be possible to modify them and prepare the special version for Kingpin. Perhaps, this procedure of the loading kernel module snd-pcm-oss won't be needed in the case of kingpin for Linux.


@ et-sdl-sound: In principal this should work but no idea how much work would be required to implement it.
@ Sin: Do you mean the use of padsp in the start script? Go for it and give it a try, if it works we could add it to the installer, but this would only be a solution for users who run Pulseaudio.

Both solutions would make the alsa oss emulation obsolete, so no need to load snd-pcm-oss anymore.

mat
Posts: 65
Joined: Mon Oct 10, 2005 18:10

Re: Kingpin does not work on Ubuntu 14.04

Postby mat » Wed Aug 19, 2015 16:21

kratz00 wrote:I am a little confused.

Does Kingpin work now (with sound)?
Do you need the echo 'kingpin.x86 0 0 direct' > /proc/asound/oss trick?.


Yes. I have the sound in the game if I type this command in the terminal:

echo 'kingpin.x86 0 0 direct' > /proc/asound/oss

Thank you.

kratz00 wrote:@ et-sdl-sound: In principal this should work but no idea how much work would be required to implement it.
@ Sin: Do you mean the use of padsp in the start script? Go for it and give it a try, if it works we could add it to the installer, but this would only be a solution for users who run Pulseaudio.

Both solutions would make the alsa oss emulation obsolete, so no need to load snd-pcm-oss anymore.


I did not know that the script for Sin use padsp because it does not work with Kingpin.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Kingpin does not work on Ubuntu 14.04

Postby kratz00 » Thu Aug 20, 2015 17:50

Good to know, thanks.

Issue solved, thread closed :D


Who is online

Users browsing this forum: No registered users and 1 guest