Deathball and airbuccaneers dont want to start

Need help with one of the installers?
Post Reply
Longkong

Deathball and airbuccaneers dont want to start

Post by Longkong » Fri Dec 24, 2004 12:58

Hi

I have problems starting airbuccaneers and deathball. The installation works good but if I try to start it:

Code: Select all

rafy@debian:~$ airbuccaneers
Exporting ONS-Adara.....Successful!
Exporting ONS-IslandHop.....Successful!
Exporting ONS-Urban.....Successful!
Exporting ONS-Tricky.....Successful!
WARNING: ALC_EXT_capture is subject to change!
_X11TransSocketOpen: socket() failed for local
_X11TransSocketOpenCOTSClient: Unable to open socket for local
_X11TransOpen: transport open failed for local/debian:0
Couldn't set video mode: Could not create GL context


History:

Exiting due to error
And deathball:

Code: Select all

rafy@debian:~$ deathball
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
UT2004 works good, also damnation and utxmp

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Fri Dec 24, 2004 13:15

did you compiled a new kernel and forgot UNIX socket support?
Not having UNIX sockets will break many programs.

Longkong

Post by Longkong » Fri Dec 24, 2004 13:57

This module is called unix, isnt it?

If yes I built it as a module and it is loaded.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Fri Dec 24, 2004 14:13

yes the modules name is unix
WARNING: ALC_EXT_capture is subject to change!
_X11TransSocketOpen: socket() failed for local
_X11TransSocketOpenCOTSClient: Unable to open socket for local
_X11TransOpen: transport open failed for local/debian:0
Couldn't set video mode: Could not create GL context
it's a typical error if you don't have this module or your /etc/host file is messed up

Asaru

Post by Asaru » Fri Dec 24, 2004 14:46

hi.. can you post the output of the logfiles pls?

/home/<user>/.ut2004/System/UT2004.log maybe you've got also
/home/<user>/.ut2004/System/AirBuccaneers.log or something like that

Longkong

Post by Longkong » Fri Dec 24, 2004 14:59

Ok thanks, you gave me an Idea. I didnt know that UT saves files outside of its directory. So I deleted the ~/.ut2004/AirBuccaneers Folder and now it works :)

However the deathball Problem is still here.

Asaru

Post by Asaru » Fri Dec 24, 2004 15:18

rafy@debian:~$ deathball
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
can you paste the output of the logfile for deathball pls? ;)
in this error message is nothing that we cann see, why it wont work for you..

Longkong

Post by Longkong » Fri Dec 24, 2004 23:24

But which logfile?

~/.ut2004/deathball/

is emty expect a System Folder with deathball.ini and deathballUser.ini

I also tried to delete them, but they will be recreated if I start it

lennart

Post by lennart » Fri Dec 24, 2004 23:42

have a look at ~/.ut2004/System . there may be a deathball.log

Longkong

Post by Longkong » Sat Dec 25, 2004 14:35

yes, here is the last part (before it looks good):

Code: Select all

Log: Initializing OpenGLDrv...
Log: binding libGL.so.1
Log: Game class is 'GameInfo'
Log: Bringing Level Entry.myLevel up for play (0) appSeconds: 3.442974...
ScriptLog: GameInfo::InitGame : bEnableStatLogging False
Warning: Missing MaterialSequence MaterialSequence 2K4Menus.Controls.background_anim
Warning: Missing Texture Texture 2K4Menus.AVPlayer.StopPressed
Log: Browse: ..\Maps\NoIntro.ut2?Name=n00b?Class=Engine.Pawn?Character=dbplayer?team=255?Sex=M?Voice=XGame.MercMaleVoice?PassAimCone=30.00?MenuMusic=True
Log:
Developer Backtrace:
Log: [ 1]  ./ut2004-bin [0x85bfc81]
Log: [ 2]  [0xffffe420]
Log: [ 3]  ./ut2004-bin(_ZN7UObject16GetPackageLinkerEPS_PKwjP11UPackageMapP5FGuidi+0x669) [0x859d029]
Log: [ 4]  ./ut2004-bin(_ZN7UObject16StaticLoadObjectEP6UClassPS_PKwS4_jP11UPackageMap+0x1f0) [0x859df50]
Log: [ 5]  ./ut2004-bin(_ZN11UGameEngine7LoadMapERK4FURLP13UPendingLevelPK4TMapI7FStringS6_ERS6_+0x2ef) [0x82346af]
Log: [ 6]  ./ut2004-bin(_ZN11UGameEngine6BrowseE4FURLPK4TMapI7FStringS2_ERS2_+0xaf2) [0x822eb42]
Log: [ 7]  ./ut2004-bin(_ZN11UGameEngine4InitEv+0x5cd) [0x822865d]
Log: [ 8]  ./ut2004-bin [0x8153c96]
Log: [ 9]  ./ut2004-bin(main+0x2f8d) [0x814f93d]
Log: [10]  /lib/tls/libc.so.6(__libc_start_main+0xf4) [0xb7d54904]
Log: [11]  ./ut2004-bin(readdir+0x99) [0x814c781]
Log: Unreal Call Stack: UObject::StaticAllocateObject <- UObject::CreatePackage <- UObject::GetPackageLinker <- UObject::StaticLoadObject <- VerifyPackages <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- InitEngine
Exit: Exiting.
Log: FileManager: Reading 0 GByte 45 MByte 349 KByte 206 Bytes from HD took 0.787845 seconds (0.347238 reading, 0.440607 seeking).
Log: FileManager: 0.000000 seconds spent with misc. duties
Uninitialized: Name subsystem shut down
Uninitialized: Allocation checking disabled
Uninitialized: Log file closed, Fri Dec 24 13:58:18 2004

Asaru

Post by Asaru » Sat Dec 25, 2004 22:18

hmm never seen this before..

you can try to find in /install/path/of/ut2k4/deathball/System
there is a special linux ini file..
try to use this.. dunno if it work ;)

Post Reply