UT2004 won't start after upgrade

Need help with one of the installers?
Post Reply
Dylanby

UT2004 won't start after upgrade

Post by Dylanby » Wed Dec 29, 2004 13:48

Last night I upgraded my UT2004 ECE to 3339 so that I could install some mods (bought the game last Friday). The game was working great (single player) prior to this.

I'm running Ubuntu "Warty" (their stable release) on the AMD64 platform.

Now when I try to start the game or one of the mods I get:

Code: Select all

./ut2004-bin: error while loading shared libraries: ./libSDL-1.2.so.0: cannot open shared object file: No such file or directory
Last night when I installed everything it was done consecutively. The upgrade followed by four mod installations, one after the other. So I'm not sure what broke what.

Dylanby

Post by Dylanby » Wed Dec 29, 2004 14:14

In /usr/lib I have:
=> 'libSDL-1.2 .so.0.7.0'
=> 'libSDL_image-1.2.so.0.1.2'

I initially installed UT2004 into my home directory so that's where I installed the mods too.

My 'libSDL-1.2.so.0' in in '/home/dylan/ut2004/system'.

I'm new to Linux so I'm suffering information overload at the moment.
I sort of learning little bits of pieces haphazardly instead of coherently.

This is probably an easy thing to fix but I'm lost. I'd like to know how to fix it, but also I'd like to know why it broke too.

Asaru

Post by Asaru » Thu Dec 30, 2004 15:03

hmm
ls -l /home/dylan/ut2004/System/lib*'
to look if all permissions on that lib are ok..
did you use our patch to upgrade ut2k4? we dont have 64bit patches at the moment.. (i do not own a 64bit cpu ;) )

Post Reply