NEVERWINTER NIGHTS

Need help with one of the installers?
kuba

NEVERWINTER NIGHTS

Post by kuba » Tue Nov 09, 2004 17:41

Hi

This messege apperad after i wrote nwn:

[kuba@PAWEL nwn]$ sh nwn
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
[kuba@PAWEL nwn]$

Please help me...
[/i]

Guest

Post by Guest » Tue Nov 09, 2004 23:37

hmm,

i don't know what this can be.

try to install nwn direct in your /home/<USER>

neo2k

Post by neo2k » Sat Jan 01, 2005 4:05

Try reinstalling SDL, if that doesn't work then try reinstalling graphic-driver, then the game.

I had that error once but can't remember exactly how i did it, but this is a start :)

zeb

The 164 installer is broken actually

Post by zeb » Sat Jan 01, 2005 12:19

Hi, actually the installer is broken.

In console, you will see that some files could not be installed, like nwn/chitin.key. If you miss that file, your install is not good.
You can check the files of your installation thanks to this thread in the linux forum of nwn:
http://nwn.bioware.com/forums/viewtopic ... 6&forum=72
and you will see that with the liflg installer ./nwn has no correct md5, and that a couple of files are missing.
The installer is based on the 164 update, which was notorious for some missing files, and people had to go back to 162 before updating again to 164.

The best way now would be to remove the liflg 164 installer, and create a new one with the 165 update. Manually, I could install nwn (using the nwnresource + 129 client + 165 update) and it works. Note: even the 165 update is incomplete (but this is less serious than for 164). You need to update the dialog.tk file after install of the 165 update (you may find it here: http://nwn.bioware.com/forums/viewtopic ... 5&forum=72

Oh, btw, happy new year :)

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Mon Jan 03, 2005 11:08

schoki is working on the 1.65 installer
yesterday he his harddrive died so the installer will be delayed

senectus

Post by senectus » Tue Jan 04, 2005 14:57

:evil: :( arrrrrggghh!

Does that mean I've just gone through the hour plus of installing NWN the two expansion packs and the ruddy patch just to find that it was never going to work in the first place?!?!

*gnash grind*

So am I to believe that the only choice I have now is to install it on a windows machine then copy it over?!
I don't have any bloody windows machines.. I've just speant the last month completely wiping windows from any PC in my house.

*sigh*
If only I had a gun :-(
I'd make sure that the next time Bioware made a port they did it fucking properly!

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Tue Jan 04, 2005 16:55

@senectus
smooth

our nwn 1.65 installers are short before release

and i don't really unterstand whats your problem?

164 is not our failure and you could use our installer and 165 to play nwn
if you know what to do
it isn't that difficult

senectus

Post by senectus » Wed Jan 05, 2005 0:31

Nah mate.. I'm not blaming you guys, you all do a pretty good job (but some sort of note on the download site saying that there are issue's please check the forums, would be nice)

I'm mostly angry at bioware for making a "port" that needs windows.

As far as I can tell I can't make it work without installing it on windows first, am I wrong there?

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Jan 05, 2005 1:40

see our testing forum
there is a nwn 165 installer

senectus

Post by senectus » Wed Jan 05, 2005 1:51

thanks mate
will get stuck into it in about 8 hours time (after work)

Guest

Sorry to report...

Post by Guest » Fri Jan 07, 2005 23:26

Sorry to report that the english installer for 1.65 gives me the same problem. Chitin.key is missing after a successful installation and nwn segfaults when trying to start.

Going to try the multilang installer + update route next...

senectus

Post by senectus » Sat Jan 08, 2005 12:46

how did that go?
I'm about to re-install again :-/

schoki

Post by schoki » Sat Jan 08, 2005 12:52

Try the installer from the testing section.
here


it seems that the english installer make some problems. :(

franz

Post by franz » Mon Jan 10, 2005 13:28

senectus wrote:Nah mate.. I'm not blaming you guys, you all do a pretty good job (but some sort of note on the download site saying that there are issue's please check the forums, would be nice)

I'm mostly angry at bioware for making a "port" that needs windows.

As far as I can tell I can't make it work without installing it on windows first, am I wrong there?
You DON'T need Windows for installing NWN and you don't need the liflg installer ... this installer makes the installation a lot easier and for me it worked but you can also install it manually;

if you have the US-Gold Edition just unzip the archives from the CDs, download the linux-client from http://nwn.bioware.com and install it following the instructions from Bioware.
the first CD contains an graphical installer for Linux but don't use it - it's broken :cry:
i have no idea why bioware isn't able to fix this and offer this installer on their website :roll:

if you have an other box of NWN you could download the full game resources from http://nwn.bioware.com :wink:
the only thing you really need is this license key from the CD case ...

regards, Franz

Darkness

Post by Darkness » Mon Jan 10, 2005 14:51

I just want to let you know that I have tried the english installers a few days ago (NWN 1.64 + SoU 1.64 + HotU 1.64) and all of three worked for me.

I updated the game to 1.65 manually without error. Before doing this I deleted override/*.

Yes, some files are duplicated and the binkplayer has no rights to run, but that is all for me.

System: debian sarge + kernel 2.6.7 + sdl libs from the system.

Darkness

p.s.: Will english installers with 1.65 patch be available for SoU and HotU?

Post Reply