Jagged Alliance 2 installer

Need help with one of the installers?
Bionic

Jagged Alliance 2 installer

Post by Bionic » Sun Jul 10, 2005 11:51

Hello everyone,
when I use the installer, I get the following error

Code: Select all

# ./jagged.alliance2_1.06b-english.run
Verifying archive integrity... All good.
Uncompressing Jagged Alliance2 1.06b-english Installer........................................................
tail: `-1' option is obsolete; use `-n 1' since this will be removed in the future
What does this mean? Can anybody help?
Many thanks in advance
Bill

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sun Jul 10, 2005 12:21

it's just a warning
does installer startup stop?

if so try

export _POSIX2_VERSION=199209

before you run the installer

Bionic

hmmmmmm

Post by Bionic » Sun Jul 10, 2005 12:30

thanks so far :) the error message is gone, but the installer still stops.

Some more information,
I put all ja2 files in one folder, the setup.sh just works fine, I downloaded the "jagged.alliance2_1.06b-english.run 1.46Mb" - file and made it executable, I did the "export _POSIX2_VERSION=199209" and when I am trying to install it it just stops

Code: Select all

Verifying archive integrity... All good.
Uncompressing Jagged Alliance2 1.06b-english Installer........................................................
Then nothing.

I am running an AMD64 and gentoo if this helps, but I have some other 32bit apps which just work fine.

thanks again,
Bill

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sun Jul 10, 2005 13:08

see our faq's if you are running x86_64

Bionic

Post by Bionic » Sun Jul 10, 2005 14:08

well, no sorry, doesn't work either.
I downloaded the linux32 files, compiled and installed them like told in the README, when I try

Code: Select all

# linux32 sh jagged.alliance2_1.06b-english.run
the same error appears, the installer just stops :cry:

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sun Jul 10, 2005 15:26

i upload jagged.alliance2_1.06b-english-2.run

try this one

Bionic

Post by Bionic » Sun Jul 10, 2005 16:06

yay, it worked, many many thanks :D

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sun Jul 10, 2005 16:12

no problem

you are welcome

Merc w/o a plan

Jagged Alliance still shows segmentation fault

Post by Merc w/o a plan » Mon Jul 18, 2005 16:33

Hey folks,

i bought the native Linux version of JA2 but i am not able to install it properly/start it.
I first tried to install JA2 in X-DSL, the Xbox port of Damn Small Linux. The installation worked fine, the game was able to start, but after clicking the start game button after changing options and choosing the difficulty level the game just crashed. I blamed it on the missing Xfree86 and Oss of XDSL so i installed GentooX, the xbox port of Gentoo.
When i tried to install the game, after having mounted the cdrom, the installation aborted with an error message like '/root/tar - no such file or directory'. Then i copied the tars from the cd into /root/tar and the installation worked fine. But when i started the game the same message as mentioned next to your download of the ja2-installer was displayed (segmentation fault). So i downloaded your installer, started it with 'sh <installername>' and a nice installation wizard appeared (great work, guys). Due to some reasons i dont know i wasnt able to choose another directory than /usr or /root but that wasnt the problem. After the installation, which was completed without any errors, i tried to start the game with ./ja2 but the same message "segmentation fault" was displayed in the terminal window. So i hope you are able to help me, i am a real noob with linux, so i would appreciate any help!

Big props for supporting the LGCommunity!

MfG
Merc

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Mon Jul 18, 2005 17:19

seem the old installer has mixed with the newer one

get rid of all ja2 releated stuff

don't forget ~/.loki/installed/ja2.xml

Merc w/o a plan

Jagged Alliance still doesnt work

Post by Merc w/o a plan » Tue Jul 19, 2005 22:00

thx 4 ya quick help, but unfortunately i dont know how to find this loki file, i used find-command in terminal window for ja2.xml and searched using my file m nager, but without success. i installed the game as root and as user, and the installation worked fine, i used ./ja2 to start the game but segmentation fault was displayed every time. but for any reason it is possible to use ./ja2 -h which is completely useless but it seems that the execution file is working. do you have an idea what segmentation fault means? i googled it but it was only described as an error in unix programming. i love ja2 so much, i have to play it, thats why i have spent about 40 hours to reach my goal, i would be so grateful if you were able to help me!

greetz
Merc

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Tue Jul 19, 2005 22:23

if you installed the game as root it's in

/root/.loki/installed/ja2.xml

as user it's in

/home/$USERNAME/.loki/installed/ja2.xml

or just simple for both ~/.loki/installed/ja2.xml

did you use our installer or the installer on cd?

Merc w/o a plan

Close to the solution

Post by Merc w/o a plan » Wed Jul 20, 2005 14:54

as described above i tried any kind of installation, w or w/o your installer, as root and as user, but starting the game never worked.
I found the lokis and deleted them, but after the last installation i noticed something strange. i clicked on the start game button of the installer, and the screen turned black for a second, like the game was trying to start. Then it was prompted that i have to mount the game disk. This is a small step to me but a huge jump to the solution. I think it doesnt work because i use the wrong command to start the game. I always go by terminal to the directory ja2 is installed to and enter ./ja2 , i tried ja2 or sh ja2 or sh ja2.sh or ja2.sh as well, but only ./ja2 worked, which means that it displayed the segmentation fault. all i need now is the command your installer is using to start the game, cause its obvious that this command doesnt produce the segmentation fault error. would you mind me giving the right commands, especially for playing windowed mode or even post a script where i can start the game with? Thanks a lot so far!

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Jul 20, 2005 15:22

the installer just use the same script as if you type ja2
the game cd is cd2 did you mount it otherwise the game won't start

ja2.sh is the script what you should start
also ja2 is a symlink to this file
but if you start ./ja2 directly your are on the wrong way :)

Merc w/o a plan

it works

Post by Merc w/o a plan » Wed Jul 20, 2005 16:37

yeeha, thx so much, its working! great, unbelievable what a game!

although you have helped me so much, one last question. i play ja2 on a tv screen with a 640x480 resolution (the only one working) but the fonts in ja2 are almost unreadable, because they are so tiny. is there ANY possibility, even modifying ja2's fontfile, to increase the size, insert a onscreen magnifying glass or something else?
thx so far and keep up the good work!

MfG
Merc w a plan

Post Reply