Glest, Warzone... SDL dependencies?

Need help with one of the installers?
Post Reply
mazka0

Glest, Warzone... SDL dependencies?

Post by mazka0 » Tue Aug 16, 2005 21:20

Hi!
I have installed Warzone 2100 and Glest with respective Loki Installers... no problem with instalation. However, when I try to run Warzone I recieve this:

Code: Select all

Error: Could not initialise SDL (SDL not built with cdrom support).
and this message with Glest:

Code: Select all

Couldn't initialize SDL: SDL not built with audio support
I use kubuntu 64 in an amd64 system

I think this is a dependencies problem with some SDL libraries... but I have installed it all! Any other package to install?

Please help me!
Thanks

GlaDiaC

Post by GlaDiaC » Tue Aug 16, 2005 23:28

Do you have you 32bit libs installed?

Warzone and Glest are 32bit only.

mazka0

Post by mazka0 » Wed Aug 17, 2005 16:29

I have the next packages that I think are needed for run 32 bit apps in 64 bit system:

ia32-libs
ia32-libs-dev
ia32-libs-gtk
ia32-libs-more
lib32gcc1
lib32stdc++6
lib32stdc++6-0
linux32

And this packages relationed with SDL:
libsdl1.2debian
libsdl1.2debian-all
libsdl1.2-dev
libsdl-console libsdl-console-dev
libsdl-erlang
libsdl-gfx1.2 libsdl-gfx1.2-dev
libsdl-image1.2 libsdl-image1.2-dev
libsdl-mixer1.2 libsdl-mixer1.2-dev
libsdl-net1.2 libsdl-net1.2-dev
libsdl-ocaml libsdl-ocaml-dev
libsdl-sge
libsdl-sound1.2 libsdl-sound1.2-dev
libsdl-ttf1.2 libsdl-ttf2.0-0

I run both installers with

Code: Select all

$ linux32 sh installer.run
Installation seems correct... but I can't execute the game.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Aug 17, 2005 18:24

it's up to us

the library which comes with the installer is missing those features

2 solutions

1. compile your own 32bit libSDL
2. wait till we fixed this problem

sorry

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Aug 24, 2005 16:14

http://liflg.org/files/libSDL-1.2.so.0
replace this one with the file in the lib subdir in the game install directory

let us know if it works

multani

Post by multani » Wed Aug 24, 2005 21:15

Yes, it works better, but there some weirdness (tested on latest Warzone's liflg installer) :
- the game start (no more "cdrom blabla" message"
- it shows this : http://multani.info/images/warzone-64.jpg
- in-game, it looks ok
- when exiting Warzone, the window turns white for a few seconds, then it kills my X session :D


Infos :
- Debian amd64 sid
- Latest Nvidia drivers


Edit: after doing some test, it appears that the "white thing" is due to my installation (same weird things in others games).

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Aug 24, 2005 23:46

whats about the warning about the screen depth?

multani

Post by multani » Wed Aug 31, 2005 19:29

Sorry for late reply ...

i don't know for the screen depth :??: But it seemes I've got the same issue with OpenGl games ... (strange colors in Enemy Territory)

multani

Post by multani » Mon Sep 12, 2005 20:14

Hi,

finally, I solved my problem using stock Nvidia drivers (instead of Debian one), and I don't get those messy colors anymore in games like ET ... but still in Warzone ...

Code: Select all

jon@deb64:~$ warzone 
Warning: Using colour depth of 32 instead of 24.
NETinitAudioCapture
Now playing music/neos_symphonie_du_vide.ogg
seq_SetSequence sequences\CAM1\c001.rpl
seq_SetSequence noVideo.rpl
seq_ShutDown
HW Tiles loaded
Now playing music/neos_aurore.ogg
audio_queuesample called - track=21
audio_queuetrack called1
Now playing music/neos_symphonie_du_vide.ogg
NETshutdownAudioCapture
NETshutdownAudioPlayback
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
/usr/local/bin/warzone: line 61:  6064 Segmentation fault      ./$GAME_BINARY "$CMD_ARGS" "$@"
jon@deb64:~$ 
The menu screen is blank (like the screenshot above), but the game looks Ok. The pasted log above is a single campagn game. The game didn't crash X anymore when exiting. I still don't know for the colour deph :(

Tell me if you want more informations.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Mon Sep 12, 2005 23:06

you can change the default depth in your xorg.conf or XFree.conf

multani

Post by multani » Sun Sep 18, 2005 13:41

X didn't want to start with a color depth of 32bits :/

I remember when I used my old Debian-32 bits installation, that I had a 24bits color depth already ...

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sun Sep 18, 2005 14:49

change it to 24 or try 16

multani

Post by multani » Wed Sep 21, 2005 18:26

It's already at 24. I will try 16bits next time.

Post Reply