Loki Installers - Nvidia driver mismatch

Need help with one of the installers?
Post Reply
Guest

Loki Installers - Nvidia driver mismatch

Post by Guest » Fri Sep 16, 2005 6:12

Hi there,

I'm curious as to how often you guys update the installers for Glest and Warzone 2100.

I've successfully installed both games, but when I try to run them I get an error message stating that my version of the Nvidia-Linux drivers are not the same as the ones used to compile the game. This isn't surprising, and I can certainly roll back the drivers to the proper version.

However, if it's just a matter of a few days or a week or so until you recompile the installer files for the newer graphics drivers, then I'd rather save myself the trouble!

Anybody know how often this sort of thing happens?

Thanks!

kratz00
liflg member
Posts: 1662
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Fri Sep 16, 2005 9:36

uh
strange you are the first one who reports this and i cant believe

because the binary has nothing to do with the nvidia driver
also what would all the ati people do?

whats the exact error message?

Guest

Post by Guest » Fri Sep 16, 2005 22:06

Hi,

Thanks for replying so quickly. Sorry if I was unclear; this is the complete console output of my installation and attempt to run Warzone 2100. I get the same error message word-for-word when I try to run Glest after install. The install itself appears to complete without error (though as you can see there are a couple of warnings).
[root@localhost Desktop]# sh warzone.2100_0.2.2-english.run
Verifying archive integrity... All good.
Uncompressing Warzone 2100 0.2.2-english Installer.......................................................
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Warning: kbuildsycoca is unable to register with DCOP.
kbuildsycoca running...
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kbuildsycoca running...
Reusing existing ksycoca
Reusing existing ksycoca
That's the install step... then I try to run the game....
[root@localhost Desktop]# warzone
Warning: Using colour depth of 32 instead of 24.
Error: API mismatch: the NVIDIA kernel module is version 1.0.7676, but
this library is version 1.0.7667. Please be sure that your kernel
module and all NVIDIA driver files have the same driver version.
Error: API mismatch: the NVIDIA kernel module is version 1.0.7676, but
this library is version 1.0.7667. Please be sure that your kernel
module and all NVIDIA driver files have the same driver version.
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
[root@localhost Desktop]#
Upon further reading, I suppose it's possible this error has nothing to do with the two games... but games like Chromium, for example, run just fine, whereas they don't without the drivers.

Thanks in advance!
-Patrick

kratz00
liflg member
Posts: 1662
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Fri Sep 16, 2005 22:48

the problem is on your side

reinstall the nvidia driver(carefully read the errormessage and think about it) :)

Post Reply