Installer for Damnation (ut2004 mod)

Need help with one of the installers?
Post Reply
dekropisvol
Posts: 14
Joined: Sun Oct 31, 2004 11:06

Installer for Damnation (ut2004 mod)

Post by dekropisvol » Sun Nov 21, 2004 11:34

Hi,

Maybe you can make an installer for this ???

I've downloaded the mod from http://www.damnationthegame.com/ and i extracted it.

cd /usr/local/games/ut2004/System
./ucc-bin umodunpack -x /path-to/Damnation_v2.ut4mod (about 408 M extracted)

The content of the umod goes into $HOME/.ut2004/damnation of the user who extracts it.

mv (or cp) $HOME/.ut2004/damnation /usr/local/games/ut2004/Damnation

Modify the /usr/local/games/ut2004/Damnation/System/Damnation.ini.

Comment with a ";" :

RenderDevice=D3DDrv.D3DRenderDevice
ViewportManager=WinDrv.WindowsClient
CdPath=D:\CD1

Uncomment:

;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;ViewportManager=SDLDrv.SDLClient

Now you can start the mod as a normal user with:

ut2004 -mod=Damnation

Asaru

Post by Asaru » Mon Nov 22, 2004 10:54

looks great.. i'll create an installer later today :)

dekropisvol
Posts: 14
Joined: Sun Oct 31, 2004 11:06

Post by dekropisvol » Mon Nov 22, 2004 21:15

@Asaru

Thank you for making this installer, i hope some other people will have fun playing it, it's a nice single player mod.

Asaru

Post by Asaru » Tue Nov 23, 2004 19:23

jeah its great..
but i cant find the entry to bind the key for healing? he told me that this key was undefinied yet ;/

dekropisvol
Posts: 14
Joined: Sun Oct 31, 2004 11:06

Post by dekropisvol » Tue Nov 23, 2004 20:35

Hi,

I have the same error, but i've binded a key to "Spirit Action" ("Control keys" section "Game") but when i push that key it works, maybe a bug or something like that.

lol

zeb

Post by zeb » Wed Nov 24, 2004 16:33

What a fine game, awesome :D
However, they don't say which license covers their mod ?

lennart

Post by lennart » Fri Dec 24, 2004 17:43

I have a great problem with this installer. It installs quite fine, but in the end there is no success screen. it just closes. there is an error message in the terminal which I don't remember now.
the game starts, but it doesnt work correctly. it crashes sometimes in the menu, very often in loadings screens when trying to load levels.

i reinstalled, same problems.

any ideas?

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Fri Dec 24, 2004 21:36

without a exact error message we can't do nothing!

thats just a useless "bugreport"

lennart

Post by lennart » Fri Dec 24, 2004 23:16

ok, here you go

Code: Select all

Verifying archive integrity... All good.
Uncompressing damnation 2.0-english Installer........................................................
Version Check: Ok
./setup.sh: line 262:  1144 Segmentation fault      "$setup" "$@"
this is written in the terminal, but the game can be run. it crashes (as described above) quite often. there are some error-logs in the log below.

error messages in ~/.ut2004/System/Damnation.log:

Code: Select all

Log: PlayAnim: Sequence 'Idle_Rest' not found for mesh 'Rourke'
Log: PlayAnim: Sequence 'Idle_Rest' not found for mesh 'Yakecan'
Log: PlayAnim: Sequence 'Idle_Rest' not found for mesh 'Zagato'
Log: 
Developer Backtrace:
Log: [ 1]  ./ut2004-bin [0x85bfc81]
Log: [ 2]  [0xffffe420]
Log: [ 3]  /usr/X11R6/lib/modules/dri/fglrx_dri.so [0x42a2ee05]
Log: [ 4]  /usr/X11R6/lib/modules/dri/fglrx_dri.so(__FGLTexMgrFreeAllNotResident
+0x16a) [0x42d8bd6a]
Log: [ 5]  /usr/X11R6/lib/modules/dri/fglrx_dri.so(fglX11AllocateManagedSurface+
0xa8) [0x42d834d8]
Log: [ 6]  /usr/X11R6/lib/modules/dri/fglrx_dri.so [0x42a2ebec]
Log: [ 7]  /usr/X11R6/lib/modules/dri/fglrx_dri.so(__glCreateObjectBuffer+0xe0) 
[0x42ce7ce0]
Log: [ 8]  /usr/X11R6/lib/modules/dri/fglrx_dri.so(__glim_NewObjectBufferATI+0x1
3e) [0x42ce7f0e]
Log: [ 9]  ./ut2004-bin(_ZN21FOpenGLIndexBufferATI5CacheEP12FIndexBuffer+0xad) [
0x872d9dd]
Log: [10]  ./ut2004-bin(_ZN22FOpenGLRenderInterface14SetIndexBufferEP12FIndexBuf
feri+0x8f) [0x872261f]
Log: [11]  ./ut2004-bin(_ZN21USkeletalMeshInstance6RenderEP13FDynamicActorP15FLe
velSceneNodeP5TListIP13FDynamicLightEPS4_IP20FProjectorRenderInfoEP16FRenderInte
rface+0x8c5) [0x83954e5]
Log: [12]  ./ut2004-bin(_ZN13FDynamicActor6RenderEP15FLevelSceneNodeP5TListIP13F
DynamicLightEPS2_IP20FProjectorRenderInfoEP16FRenderInterface+0xd94) [0x831a364]
Log: [13]  ./ut2004-bin [0x83402fc]
Log: [14]  ./ut2004-bin(_Z11RenderLevelP15FLevelSceneNodeP16FRenderInterface+0x1
031) [0x833cd81]
Log: [15]  ./ut2004-bin(_ZN15FLevelSceneNode6RenderEP16FRenderInterface+0x66c) [
0x8323b2c]
Log: [16]  ./ut2004-bin(_ZN16FPlayerSceneNode6RenderEP16FRenderInterface+0x1da) 
[0x8327eba]
Log: [17]  ./ut2004-bin(_ZN11UGameEngine4DrawEP9UViewportiPhPi+0x12ca) [0x82443f
a]
Log: [18]  ./ut2004-bin(_ZN12USDLViewport7RepaintEi+0x56) [0x87127f6]
Log: [19]  ./ut2004-bin(_ZN10USDLClient4TickEv+0x159) [0x8710a19]
Log: [20]  ./ut2004-bin(_ZN11UGameEngine4TickEf+0x52a) [0x82484ba]
Log: [21]  ./ut2004-bin(_ZN9CMainLoop7RunLoopEv+0x108) [0x815bc08]
Log: [22]  ./ut2004-bin [0x815362f]
Log: [23]  ./ut2004-bin(main+0x2c8f) [0x814f63f]
Log: [24]  /lib/libc.so.6(__libc_start_main+0xe0) [0x401963f0]
Log: [25]  ./ut2004-bin(readdir+0x99) [0x814c781]
Log: Unreal Call Stack: FOpenGLIndexBufferATI::Cache <- FOpenGLRenderInterface::
SetIndexBuffer <- USkeletalMeshIns
fglrx can be read quite often. I use an ati radeon 9600 mobility. normal ut2004 doesn't complain, except in some levels.

when i have a freshly installed damnation i can play. but when i shut down and restart, it isn't working.

Post Reply