UT99 runs way too fast

Need help with one of the installers?
treeroot

UT99 runs way too fast

Post by treeroot » Thu May 25, 2006 19:19

Hello!
I have installed Unreal Tournament 99 on my Notebook using the 436-non-GOTY-installer from liflg.org.
Installation went fine, no Problems.
But when I start ut, it runs way too fast. somehow the delay between frames doesn't seem to work.
On another Computer, the same combination of installer and UT-CD works fine.

My Computer:
Dell Latitude D610 Notebook
Intel PM 1,6GHz
Intel 915GM graphics chipset
1GB DDR2 RAM

Linux Distribution:
Ubuntu Dapper Drake Beta (updated daily, not an old version)

Thank you!

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sat May 27, 2006 11:24

are you using "cool'n'quiet" or something similar?

try to set the performance to the max before you start or deactivate the feature

also google has some good hints

treeroot

Post by treeroot » Sat May 27, 2006 13:50

I really do use powernowd .
Thank you, I'll try disabling it.

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sat May 27, 2006 14:06

please report back

maybe it will help others with the same problem, thx

treeroot

Post by treeroot » Sat May 27, 2006 15:30

Well, it works now. Switching off powernowd didn't change anything, so I booted with acpi=off. Still doesn't run very smooth, though... But thanks.

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sat May 27, 2006 15:54

it works but it's dosen't run smooth

what do you mean with that? :)

treeroot

Post by treeroot » Sat May 27, 2006 16:30

It doesnt run too fast anymore, but about every second, it suddenly slows down and speeds up again. But I didn't think this had anything to do with the topic of my initial post, so I didn't explain more precisely.

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sat May 27, 2006 16:40

i think the problem is related to your initial problem

what you experience is that the cpu switches between different steppings

treeroot

Post by treeroot » Sat May 27, 2006 21:32

So how can I stop the CPU from doing that? I have already turned ACPI off ...

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sun May 28, 2006 19:50

sorry no idea
i don't own such hardware

google should be your friend :)

malte

Post by malte » Tue May 30, 2006 2:27

I was having the same problem, thank you kratz00, it really was cpufreq messing with UT :)
treeroot: no need to turn ACPI off, if you have Ubuntu, PM me!

malte`

P.S.: first post, hi there :wink:

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Tue May 30, 2006 8:57

Hi malte, welcome to the forum.

Would you be so nice to post your solution here, so others could read it.

Thank you.

malte

Post by malte » Wed May 31, 2006 15:43

You can disable Cool'n'Quiet from the BIOS or on Ubuntu:

Code: Select all

sudo chmod +s /usr/bin/cpufreq-selector
add the CPU Frequency applet on your GNOME panel and set the Governor to 'performance' from there.

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Thu Jun 01, 2006 10:27

thx malte, i hope this will help people who have the same problem

Tiago Cruz

Post by Tiago Cruz » Wed Jun 07, 2006 4:04

Hello all,

I have a Dell D510 (Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller) and I'm with this problem too: Running so fast to me :(

I'm running on Ubuntu Dapper, and I has been seted the speed on game to 50% (worked on windows) and notthing.

Without powerd and with my CPU with 800 MHz (46 %) don't work too :-(

Somebody can help me?

Thaanks!!! :wink:

Post Reply