Doom 3 won't run

Need help with one of the installers?
Locked
Rivaldi

Doom 3 won't run

Post by Rivaldi » Sat May 27, 2006 1:05

Hello,
I used the doom 3 installer off this site and everything seemed to intall fine. WHen I try to run it the screen goes black for a few seconds then closes. The console says this:

Code: Select all

DOOM 1.3.1302 linux-x86 May 12 2005 14:56:44
found interface lo - loopback
found interface eth0 - ***.***.*.*
------ Initializing File System ------
Loaded pk4 /home/resh/games/doom3/base/game01.pk4 with checksum 0xe9d5adcf
Loaded pk4 /home/resh/games/doom3/base/game02.pk4 with checksum 0x80401dd2
Loaded pk4 /home/resh/games/doom3/base/game03.pk4 with checksum 0x351c23e8
Loaded pk4 /home/resh/games/doom3/base/pak000.pk4 with checksum 0x28d208f1
Loaded pk4 /home/resh/games/doom3/base/pak001.pk4 with checksum 0x40244be0
Loaded pk4 /home/resh/games/doom3/base/pak002.pk4 with checksum 0xc51ecdcd
Loaded pk4 /home/resh/games/doom3/base/pak003.pk4 with checksum 0xcd79d028
Loaded pk4 /home/resh/games/doom3/base/pak004.pk4 with checksum 0x765e4f8b
Loaded pk4 /home/resh/games/doom3/base/pak005.pk4 with checksum 0x8ffc3621
Loaded pk4 /home/resh/games/doom3/base/pak006.pk4 with checksum 0x95b65ab
Loaded pk4 /home/resh/games/doom3/base/pak007.pk4 with checksum 0x666bdb3c
Current search path:
/home/resh/.doom3/base
/home/resh/games/doom3/base
/home/resh/games/doom3/base/pak007.pk4 (38 files)
/home/resh/games/doom3/base/pak006.pk4 (48 files)
/home/resh/games/doom3/base/pak005.pk4 (63 files)
/home/resh/games/doom3/base/pak004.pk4 (5137 files)
/home/resh/games/doom3/base/pak003.pk4 (4676 files)
/home/resh/games/doom3/base/pak002.pk4 (6120 files)
/home/resh/games/doom3/base/pak001.pk4 (8972 files)
/home/resh/games/doom3/base/pak000.pk4 (2698 files)
/home/resh/games/doom3/base/game03.pk4 (2 files)
/home/resh/games/doom3/base/game02.pk4 (2 files)
/home/resh/games/doom3/base/game01.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
Addon pk4s:
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
5206 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
couldn't exec DoomConfig.cfg
couldn't exec autoexec.cfg
5206 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Setup X display connection
dlopen(libGL.so.1)
Initializing OpenGL display
Using XFree86-VidModeExtension Version 2.2
DGA DirectVideo Mouse (Version 2.0) initialized
Free86-VidModeExtension Activated at 640x480
Using 8/8/8 Color bits, 8 Alpha bits, 24 depth, 8 stencil display.
GL_RENDERER: GeForce FX 5200/AGP/SSE2/forceSW
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_imaging GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_HP_occlusion_test GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_clamp GL_NV_fog_distance GL_NV_fragment_program_option GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_texgen_reflection GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_program2_option GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_multi_draw_arrays GL_SUN_slice_accum

------- Input Initialization -------
XKB extension: compile time 0x1:0x0, runtime 0x1:0x0: OK
XKB extension present on server ( 0x1:0x0 )
------------------------------------
dlopen(libasound.so.2)
asoundlib version: 1.0.9
Alsa is available
------ Alsa Sound Initialization -----
opened Alsa PCM device default for playback
device buffer size: 15052 frames ( 60208 bytes )
allocated a mix buffer of 16384 bytes
--------------------------------------
...using GL_ARB_multitexture
...using GL_ARB_texture_env_combine
...using GL_ARB_texture_cube_map
...using GL_ARB_texture_env_dot3
...using GL_ARB_texture_env_add
X..GL_ARB_texture_non_power_of_two not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
   maxTextureAnisotropy: 8.000000
...using GL_EXT_texture_lod
...using GL_1.4_texture_lod_bias
...using GL_EXT_shared_texture_palette
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
X..GL_ATI_text_fragment_shader not found
X..GL_ARB_vertex_buffer_object not found
...using GL_ARB_vertex_program
...using GL_ARB_fragment_program
X..EXT_depth_bounds_test not found
---------- R_NV20_Init ----------
Not available.
----------- R200_Init -----------
Not available.
---------- R_ARB2_Init ----------
Available.
---------------------------------
----- R_ReloadARBPrograms -----
glprogs/test.vfp
glprogs/test.vfp
glprogs/interaction.vfp
glprogs/interaction.vfp
glprogs/bumpyEnvironment.vfp
glprogs/bumpyEnvironment.vfp
glprogs/ambientLight.vfp
glprogs/ambientLight.vfp
glprogs/shadow.vp
glprogs/R200_interaction.vp
glprogs/nv20_bumpAndLight.vp
glprogs/nv20_diffuseColor.vp
glprogs/nv20_specularColor.vp
glprogs/nv20_diffuseAndSpecularColor.vp
glprogs/environment.vfp
glprogs/environment.vfp
glprogs/arbVP_glasswarp.txt: File not found
glprogs/arbFP_glasswarp.txt: File not found
-------------------------------
WARNING: vertex array range in virtual memory (SLOW)
signal caught: Segmentation fault
si_code 1
Trying to exit gracefully..
Shutting down sound hardware
----------- Alsa Shutdown ------------
close pcm
dlclose
--------------------------------------
idRenderSystem::Shutdown()
At the begining it mentions that it can't exicute some .cfg files. I have read/write permissions on the directory I installed it to but I cannot find any of these files on my computer.

It also mentions a lot about graphics. I have no idea what any of that stuff means. I have a geforce fx 5200 (128) with Nvidea drivers, I installed them a few months ago so I think they are the newest. glxgears shows around 1400 FPS.

Any help would be much appreciated.
Thank you.

-Rivaldi

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sat May 27, 2006 11:10

hi

whats the ouput of

glxinfo | grep render

and

cat /proc/driver/nvidia/version

and

xdpyinfo | grep 'depth of root window'

and finally

cat /proc/asound/version

Rivaldi

Post by Rivaldi » Sat May 27, 2006 15:22

Here are the outputs:

glxinfo | grep render

Code: Select all

direct rendering: No
OpenGL renderer string: GeForce FX 5200/AGP/SSE2
cat /proc/driver/nvidia/version

Code: Select all

NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module  1.0-8178  Wed Dec 14 16:22:51 PST 2005
GCC version:  gcc version 4.0.1 (4.0.1-5mdk for Mandriva Linux release 2006.0)
xdpyinfo | grep 'depth of root window'

Code: Select all

depth of root window:    24 planes
cat /proc/asound/version

Code: Select all

Advanced Linux Sound Architecture Driver Version 1.0.9b.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sat May 27, 2006 15:53

the driver of your grapics card isn't installed/setup properly
otherwise it would be "direct rendering: Yes"

if you use google you will find enough good tutorials how to do this

and it's also a chance to update to the latest version of the Nvidia drivers :)

color depth @ 24 is ok and recommended

there is also a newer Alsa release but this shouldn't matter

Rivaldi

Post by Rivaldi » Mon May 29, 2006 23:08

After two days of trying to install the driver I finally got it to work and doom seems to work fine now. Thank you for your help.

-Rivaldi

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Tue May 30, 2006 8:55

Congratulation Rivaldi and have fun with doom.

You are welcome.

closed :)

Locked