Troubles with Megapack and some installers for UT2004

Need help with one of the installers?
Post Reply
Starcrasher

Troubles with Megapack and some installers for UT2004

Post by Starcrasher » Fri Jun 30, 2006 13:44

On a fresh install of UT2004, I tried near all installers (I didn't try other because they were outdated: UnWheel release is now R5, UTXMP is now PR beta 3). Alien Swarn is outdated too but it's only a one file patch to 1.31

I had some problems with few of them :

Air Bucanneers as trouble to create a symlink for airbuccanneers-srv
loki_setup: Can't create /usr/bin/airbuccaneers/srv : N'est pas un répertoire
(In english : Is not a directory)

COR and Unreal4Ever don't recognize the megapack has an ECE-Bonus Pack replacement
# ./cor_beta1.01-english.run
Verifying archive integrity... All good.
Uncompressing COR beta1.01-english Installer..........................................................
Version Check: Ok
ECE-Bonus Pack Check: FAILED
Please install ECE-Bonus Pack first!!

CTF4 and StrikeForce Installers ends with a segfault a line 154
# ./ctf4_1.0.1.1-english.run
Verifying archive integrity... All good.
Uncompressing CTF4 1.0.1.1-english Installer.................................... .................
Version Check: Ok
./setup.sh: line 154: 25537 Erreur de segmentation (core dumped) "$setup" "$@"

It could be nice to have an installer for BR4 as it's required for CTF4 Skyline map to work.

Another installs fine but crashed on first launch. I think it was Domain 2049, but I'm not really sure.

If other updates are planned or for people who don't want to install megapack, it could be nice to fix the url that still point to http://unreal.epicgames.com/updates in manifest.

Thanks for all this work, it's impressive.

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Mon Jul 03, 2006 0:10

thanks for the feedback

it's on my todo list

what is br4?

spans

Post by spans » Mon Jul 03, 2006 1:13

Hi, I am sorry if it isn't much help, I am running suse 10.0, installed the cd version of UT2004, all ok, downloaded the megapack, ran that , and sadly UT won't start now, I have checked the 2 bin files are correct and in the system directory, and I have tried removing the .ut2004 directory but to no avail, I will do a re-intall of the whole thing, and try again, I just wanted to ask if anyone out there has managed to get it all to work.

Oops my machine is AMD64 3800, 1 gig ram, loads of hard drives, suse 10.0, Nvidia 6800gt.

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Mon Jul 03, 2006 6:22

spans wrote:Hi, I am sorry if it isn't much help, I am running suse 10.0, installed the cd version of UT2004, all ok, downloaded the megapack, ran that , and sadly UT won't start now, I have checked the 2 bin files are correct and in the system directory, and I have tried removing the .ut2004 directory but to no avail, I will do a re-intall of the whole thing, and try again, I just wanted to ask if anyone out there has managed to get it all to work.

Oops my machine is AMD64 3800, 1 gig ram, loads of hard drives, suse 10.0, Nvidia 6800gt.
please open a new thread
your problem isn't related to Starcrasher's one
and a error message would be helpful too

Starcrasher

Post by Starcrasher » Tue Jul 04, 2006 7:37

So, what is BR4 ? In fact, it's the same thing as CTF4/TDM4 but for Bombing Spree. You can find it there : http://uncommonplace.com/games/br4.html
The only problem is that it's dependant of CTF4 but it brings some files needed by CTF4 Skyline map since it has own version of this map.

By the way, I tried to install SAS 3.1 from their installer after fresh reinstalling DVD and megapack : It ends with UT version 3355 or above is needed. It's seems like problems are relative to the manifest. I took a look at it, and there's no reference of the new version nor of the ece-bonus pack.

For Domain 2049, maybe the problem is only coming from the ini files I didn't copy like it's said in another thread.

Installer for the Soulkeeper-SE should be fine. ( http://thesoulkeeper.helm-systems.com/soulkeeper/ ). But you have to dowload it eslsewhere like ie Beyond Unreal for the SE thing. It's really heavy to install, the zip file is near 1Go and you have to decompress it two times (there are two zip files in). The second time it's more than 2 Go that are decompressed.

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Re: Troubles with Megapack and some installers for UT2004

Post by kratz00 » Sun Jul 16, 2006 17:34

Starcrasher wrote:On a fresh install of UT2004, I tried near all installers (I didn't try other because they were outdated: UnWheel release is now R5, UTXMP is now PR beta 3). Alien Swarn is outdated too but it's only a one file patch to 1.31
you are right and i'm going to update all of them step by step
thx for the information
Starcrasher wrote: I had some problems with few of them :

Air Bucanneers as trouble to create a symlink for airbuccanneers-srv
loki_setup: Can't create /usr/bin/airbuccaneers/srv : N'est pas un répertoire
(In english : Is not a directory)
it's a typo in setup.xml, i will upload a new package soon
Starcrasher wrote: COR and Unreal4Ever don't recognize the megapack has an ECE-Bonus Pack replacement
# ./cor_beta1.01-english.run
Verifying archive integrity... All good.
Uncompressing COR beta1.01-english Installer..........................................................
Version Check: Ok
ECE-Bonus Pack Check: FAILED
Please install ECE-Bonus Pack first!!
this is a relict of the old ece installer which isn't needed anymore since it's part of the megapack, so we have to update all installer which depend on the ece pack
Starcrasher wrote: CTF4 and StrikeForce Installers ends with a segfault a line 154
# ./ctf4_1.0.1.1-english.run
Verifying archive integrity... All good.
Uncompressing CTF4 1.0.1.1-english Installer.................................... .................
Version Check: Ok
./setup.sh: line 154: 25537 Erreur de segmentation (core dumped) "$setup" "$@"
i'm not sure whats the problem here
Starcrasher wrote: It could be nice to have an installer for BR4 as it's required for CTF4 Skyline map to work.
i have to check this but i thought ctf4 dosen't need
Starcrasher wrote: Another installs fine but crashed on first launch. I think it was Domain 2049, but I'm not really sure.
did you check the logfiles?
try to "remove" ~/.ut2004
Starcrasher wrote: If other updates are planned or for people who don't want to install megapack, it could be nice to fix the url that still point to http://unreal.epicgames.com/updates in manifest.

Thanks for all this work, it's impressive.
you mean the update url of ut2004?

Starcrasher

Post by Starcrasher » Mon Aug 28, 2006 12:44

I found out another little thing : Some Mods put their log files in $HOME/.ut2004/System directory and some other in $HOME/.ut2004/NAME_OF_THE_MOD/System one. It could be fine to unify one or the other behaviour.

Now, for previously reported problems :

Domain 2049 : I had to copy the .ini files since those autogenerated didn't work.

BR4 : Only the CTF4 Skyline map need it, all other CTF4 stuff works fine without it.

./setup.sh : line 154: 25537 Erreur de segmentation (core dumped) "$setup" "$@" : I think (not sure) it was because I didn't have insalled the Loki uninstaller before. Now,I don't have this error anymore.

Updating all installers wich depends on ece pack is a huge work. Isn't it another solution?

And finally : Yes, I was thinking about the update url of ut2004.

Post Reply