UT2004

Need help with one of the installers?
Post Reply
SuperPat

UT2004

Post by SuperPat » Sat Nov 18, 2006 18:46

Hello,

Since I upgrade to Mandriva 2007 PowerPack, UT2004 refuse to start.

First, the splash screen appear transparent
and the black windows appear an finally return to the desktop.

UT exit with error:

Code: Select all

Xlib: extension "XFree86-DRI' missing on display ":93.0"
WARNING: ALC_EXT_capture is subject to change!

Either GL_EXT bgra or glDrawRangeElements not supported- bailing out.

History:

Exiting due to error
The UT2004.log:

Code: Select all

Log: Log file open, Sat Nov 18 18:03:52 2006
Init: Name subsystem initialized
Init: Version: 3369 (128.29)
Init: Compiled: Dec 16 2005 13:23:47
Init: Command line: 
Init: (This is Linux patch version 3369.2)
Init: Character set: Unicode
Init: Base directory: /usr/local/games/ut2004/System/
Init: Ini:UT2004.ini   UserIni:User.ini
Init: Build label: UT2004 Build UT2004_Build_[2005-11-23_16.22]
Init: Object subsystem initialized
Warning: Missing Sound Sound AnnouncerMale2K4.Generic.20_seconds
Log: Initializing OpenGLDrv...
Log: binding libGL.so.1
Log: Game class is 'GameInfo'
Log: Bringing Level Entry.myLevel up for play (0) appSeconds: 12.516060...
ScriptLog: GameInfo::InitGame : bEnableStatLogging Faux
Log: Browse: NvidiaLogo.ut2?Name=Player?Class=Engine.Pawn?Character=Jakob?team=255
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 33857->33854; refs: 350140
Log: Game class is 'CinematicGame'
Log: Bringing Level NvidiaLogo.myLevel up for play (0) appSeconds: 14.519331...
ScriptLog: GameInfo::InitGame : bEnableStatLogging Faux
Log: Created and initialized a new SDL viewport.
Log: ALAudio: Using ALC_EXT_capture to record audio.
ScriptLog: New Player Player id=a35c67df5c29322b41b513cef6be2ad9
Log: TTS: No output filename specified.
Log: Enter SetRes: 800x600 Fullscreen 1
Log: OpenGL
Log: GL_VENDOR     : ATI Technologies Inc.
Log: GL_RENDERER   : RADEON 9600 Generic
Log: GL_VERSION    : 1.2 (2.0.6011 (8.28.8))
Log: OpenGL: Device supports: GL
Log: OpenGL: Device supports: GL_ARB_texture_cube_map
Log: OpenGL: Device supports: GL_ARB_texture_env_combine
Log: OpenGL: Device supports: GL_EXT_texture_lod_bias
Log: OpenGL: Device supports: GL_ARB_multitexture
Log: OpenGL: C32 RGB888 Z24 S8
Log: OpenGL: Not using multisample
Log: WARNING: OpenGL renderer relies on DXTC/S3TC support for good performance.
Log: WARNING: no support for combine3/4 extensions -> not all blend modes supported
Critical: Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.
Exit: Executing UObject::StaticShutdownAfterError
Exit: Executing USDLClient::ShutdownAfterError
Log: Waiting for file streaming thread to finish...
Exit: OpenAL Audio subsystem shut down.
Exit: Exiting.
Log: FileManager: Reading 0 GByte 40 MByte 548 KByte 150 Bytes from HD took 10.417891 seconds (10.417891 reading, 0.000000 seeking).
Log: FileManager: 0.000000 seconds spent with misc. duties
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, Sat Nov 18 18:04:17 2006
I use ATI fglrx driver (installed by mandriva) with XGL/Compiz.

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sun Nov 19, 2006 19:04

Either GL_EXT bgra or glDrawRangeElements not supported- bailing out.

<-- this seems to be the problem

update your graphics driver and try to disable xgl

Post Reply