Ubuntu 6.10 Quake 2 startup "Syntax error: Bad substitu

Need help with one of the installers?
Locked
mwk2916

Ubuntu 6.10 Quake 2 startup "Syntax error: Bad substitu

Post by mwk2916 » Mon Apr 09, 2007 18:04

:~$ quake2
/usr/local/bin/quake2: 31: Syntax error: Bad substitution

This is the error I'm getting after installing quake2_3.21-r0.16.1-english.run and trying to start the Quake 2 demo for the first time. If this is an error in the installer how can I be the only one getting it? Would appreciate any suggestions. Thanx!

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Tue Apr 10, 2007 12:59

change the first line of the quake2 script from #!/bin/sh to #!/bin/bash

mwk2916

Ubuntu 6.10 Quake 2 startup "Syntax error: Bad substitu

Post by mwk2916 » Tue Apr 10, 2007 14:33

Figures it be something that simple. Excellent installer. Thank you!

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Tue Apr 10, 2007 20:54

You are welcome and thank you too.

Locked