Alpha Centauri

Need help with one of the installers?
Post Reply
Phoboss

Alpha Centauri

Post by Phoboss » Thu May 31, 2007 23:12

I am having trouble with alpha centaury planetary pack. I am running it under Ubuntu feisty. It installs just fine, it loads up fine too, but after a few turns, most likely when a new window pops up, i get this error in terminal:
"X Error: BadMatch
Request Major code 66 ()
Error Serial #581
Current Serial #584"

The two last numbers always differ, but the difference between them is always 3.
Thanks.

*later edit* In my neverending wisdom I forgot to mention that the game actually crashes when I receive that error message.

Stormspire

Post by Stormspire » Thu Jun 07, 2007 2:41

Yep, I'm having the exact same problem under Ubuntu feisty. I'm searching around for a work-around, but so far there have been no leads.

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Thu Jun 07, 2007 16:19

I can't say this works because I can't try it myself because I don't own the game but have a look at:

http://gentoo-wiki.com/HOWTO_Running_Ol ... a_Centauri

Stormspire

Post by Stormspire » Sat Jun 16, 2007 6:03

Ok, I haven't tried this yet, but it looks pretty promising. It seems the one who posted this got SMAC to work fully...even with multiplayer! I am downloading the patch right now and will post my results when I'm through.

Here is the link:
http://lordhedgehog.hedgie.com/smac/

kratz00
liflg member
Posts: 1664
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Mon Jun 18, 2007 9:14

whats the status?

Slammer64

Post by Slammer64 » Mon Jun 25, 2007 21:39

The key to running SMACX under Linux on modern distros is to turn anything to do with AIGLX/Compiz off. You need to modify your xorg.conf so that compositing is turned off. I have run SMACX under Fedora 7 Kubuntu 7.04 and openSUSE10.2 this way with no problems.

Phoboss

Post by Phoboss » Sun Jul 01, 2007 12:30

Slammer64 wrote:The key to running SMACX under Linux on modern distros is to turn anything to do with AIGLX/Compiz off. You need to modify your xorg.conf so that compositing is turned off. I have run SMACX under Fedora 7 Kubuntu 7.04 and openSUSE10.2 this way with no problems.
Thanks for the reply, i looked through the corg.conf file and couldn't find any line containing "compositing". I am still new to linux, so could you walk me through the process?

Thanks

Stormspire

Post by Stormspire » Tue Jul 24, 2007 20:12

I got it running a while ago - I made a how-to on the ubuntu forums. Check the bottom of this page:

http://ubuntuforums.org/showthread.php?t=345846&page=2

Post Reply