NWN: Sound disabled

Need help with one of the installers?
Post Reply
Wesley

NWN: Sound disabled

Post by Wesley » Wed Sep 26, 2007 8:28

hi
I am using your nwn installer(besides, thanks for this great peace of work).
I installed it like mentioned by various threads in this forum:
insert the cds like requested, patch directly with the patch for my language(german).

all worked just fine, i tryed the game out, and it runs pretty smooth and (nearly) without errors.
the only problem i got is that the program disables sound while starting nwnmain.
the output of the terminal is:

Code: Select all

SDL: Audio timeout - buggy audio driver? (disabled)
audio: Bad file descriptor
i got an onboard Soundcard, an SIS Chipset, the board manufacturer is "ASRock".
I was using the OSS driver for soundoutput, they where working just fine for any other application, after the error occurs, i switched to ALSA, without actual changes of the error.
I also tryed out the 2 different soundsettings ingame, but there where still no change in the behavour(and since im not realy sure what they do anyway i dont know if i was on the right path to a solution anyway o.0).

If i didnt stated the problem clearly, please let me know.

Wesley

Post by Wesley » Sat Sep 29, 2007 12:23

i actually got it to run, with this way:
setting audio output to alsa under gnome.
editing the run script so that he dont loads "./lib" but "/usr/lib"
setting SDL_AUDIODRIVER to alsa (any other driver made the music stuttering)

EDIT
i would like to ask if this solution is actually "good" or is it just an ugly workaround for an error that is on my system, and not on the linux binary or any parts(libs) of it?

kratz00
liflg member
Posts: 1658
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Sat Sep 29, 2007 17:52

No hack at all :)

NWN comes bundled with it's own version of SDL, if you want to use your system-wide installed one remove "./lib", you don't need to set it to "/usr/lib" because it's a default location for libraries

and for the second part of your question:

http://www.icculus.org/lgfaq/#setthatdriver

Post Reply