Help Game Speed problem - UT GOTY and Serious Sam SE

Need help with one of the installers?
eyej

Help Game Speed problem - UT GOTY and Serious Sam SE

Postby eyej » Sun Dec 06, 2009 16:23

Hello I have a problem I can't find a solution for a problem with Unreal Tournament GOTY and Serious Sam the second encounter

I installed UT and it seems to run fine except for one problem:
The game speed seems to depend on the frame-rate. It seems that the smaller the resolution I set in Unreal Tournament the faster the character runs and everything else is faster to. Also it changes while playing the game sometimes reaching almost normal speed and sometimes I zoom trough the level like superman at light speed.
I remember having the same problem with Serious Sam back when I tried installing it. The game speed in the config is set to 100% so that can't be the problem. UT2004 on the other hand was running fine when I had it installed on Ubuntu

Thanks for reading, any ideas hot to fix this and what might be causing the problem?

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Mon Dec 07, 2009 22:54

Hi eyej,

CPU throttling will cause this issue. UT
(and other games based on the same game engine ) will determine the speed at the game engine launch and your CPU will throttle at this time. So momentarily turning off the CPUspeed service or cpufreq or whatever it would be, should solve this problem for you or you could try this script:

http://liflg.org/files/ut

(backup the old one before replacing it)

Regards
-Steffen

eyej

Hi kratz00

Postby eyej » Wed Dec 09, 2009 0:33

Thank you for your reply I tried that script and various other methods:

seting the cpu to be at 100% on all 4 cores trough the gnome frequency applet.
i also tried to disable throttling using rcconf and the bios.
It seems to have helped alittle but the problem is not gone. I guess older games just wont work then?

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Wed Dec 09, 2009 17:00


Jusko
Posts: 21
Joined: Sat Aug 09, 2008 14:54

Postby Jusko » Wed Jan 20, 2010 1:20

When UT Liflg installer will be updated to 451 version (http://www.utpg.org/)? UT 436 is hard to run on many modern distros.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Wed Jan 20, 2010 19:07

Hi Jusko,

sounds like a good idea, till then you can use our installer and extract UTPGPatch451.tar.bz2 inside the installation directory.

eyej

451 fixes speed problem?

Postby eyej » Wed Jan 20, 2010 23:38

Does the 451 version fix the speed problem for linux?

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Wed Jan 20, 2010 23:45

Hi eyej,

no idea, but why don't you find out? :)
Please report back.

Jusko
Posts: 21
Joined: Sat Aug 09, 2008 14:54

Re: 451 fixes speed problem?

Postby Jusko » Thu Jan 21, 2010 2:51

eyej wrote:Does the 451 version fix the speed problem for linux?


No (some people says that 451 fixed this problem on their PC). Still i have speed problem. I've tested a hundred method for this speed issue, but...nothing. It's Unreal Engine fault - it's maybe impossible to fix this in that case. This issue is mostly on x86_64 processors or 2 and higher cores. My speed problem is little strange, because game is not always at 200% of game speed, but sometimes it's too sloow, then speed up to 150%, and few second later it's too slow again...speed-jumping :roll:

EDIT:

Tip from Ubuntu forum seems working...

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Postby rettichschnidi » Thu Jan 21, 2010 8:34

Just disable the speedstepping-stuff and it should work

eyej

Postby eyej » Thu Jan 21, 2010 9:45

Well last time I tried I had no luck with any methods I could find on the forums. I'l try again when I get the time to do so and I'l make sure to report back my progress ;)

Jusko what exact method did work for you?
I have a very similar problem to yours and I to have concluded that the engine has just a really stupid design flaw using CPU freq as the means of measuring time. It was probably a good idea back when there were no multi-core cpu's since it probably saved some performance.

Jusko
Posts: 21
Joined: Sat Aug 09, 2008 14:54

Postby Jusko » Thu Jan 21, 2010 14:07

rettichschnidi - How?

eyej

http://ubuntuforums.org/showthread.php?t=320425

Of course you may install UT in your own directory. Then set right path in script and run game from utmakebusy script. Of course i've tested this script maybe 30 seconds, but seems to work.

Unreal Engine was not designed for multi-core CPU's. Even on Wine games builded on Unreal Engine have this problem (like Clive Barker Undying or sometimes Deus Ex). This games are from 1998-2001 (from Unreal 1 to DeusEx). Today we have 2010 and totally different PC - 4GB RAM, 8 cores CPU's. Shame that Epic do nothing with this. I've builded native installer for Unreal 1 - OldUnreal community send e-mail to Epic about make this installer official for GNU/Linux port of game. They even not respond. Few years more and this game will be unplayble on all systems.

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Postby rettichschnidi » Thu Feb 11, 2010 21:37

Try this (untested):

Code: Select all

( TIMENOW=`date +%S`;while [ `expr $TIMENOW + 5` -gt `date +%S` ];do echo helo > /dev/null; done )& sleep 2;ut


Who is online

Users browsing this forum: No registered users and 1 guest