Page 1 of 1

Serious Sam TFE, no sound, help?

Posted: Sun Apr 11, 2010 2:03
by quadomatic
I installed Serious Sam The First Encounter. It runs fine, but I can't seem to get sound working.

I've tried changing the SDL_AUDIODRIVER setting to both "alsa", "pulse", and "esd". None of them are working. The only thing that works is DSP, but this causes all other programs to lose sound.

For RTCW, I have no problems using the et-sdl-sound hack and setting SDL_AUDIODRIVER="alsa"

What can I do?

Posted: Wed Apr 14, 2010 18:56
by kratz00
Good question :)
There should be a dynamic linked executable if I remember correctly, does this change anything?

Re: Serious Sam TFE, no sound, help?

Posted: Fri Jan 25, 2013 23:09
by nod
I had this problem, if I tried to set audio frequency it would complain with SDL_OpenAudio() error: No available audio device

I fixed it by starting ssamtfe with the PulseAudio OSS Wrapper:

$ padsp ssamtfe

BTW I very nearly didn't get to post this, your anti spam question is also an anti person question, I had NFI what the right surname was, had to click around a bunch of pages to find the right surname here: