Page 1 of 1

no sound with quake 1 and unreal tournament (Fedora13)

Posted: Thu Aug 05, 2010 22:49
by tja1618
Hello all!

First of all, I am very grateful for the installers as it is, the games seem to run fine, except for the fact that I can't get any sound.

Both are looking for the oss relic, /dev/dsp which is not on my Fedora 13 system. I have all the alsa-oss packages installed that I can find in my repos, but still no go.

I imagine, without modification to the games, that I would still need some sort of device files (/dev/dsp) in place anyway, I posted this same thing a, so I will include my original post there.

NOTE: with UT, I get the same message "/dev/dsp: No such file or directory". For obvious reasons. I was hoping someone in the community has conquered this issue with oss emulation.


After finally getting my 3d graphics configured (thanks to leigh123linux!) I now am trying to tackle my sound issue. The end result is that I want to play equake (from loki installers). The game seems to run fine, except that I get no sound.

Now I know that OSS sound is going the way of the dinosaur in favor of Alsa, but I know people with older distributions have got OSS emulation working. I have all the alsa-oss packages installed that are available in my repos, but I still cannot get any sound in equake.

Also, I have tried the wrapper program, padsp, with no success.

Code: Select all

 [tja@area51m ~]$ padsp equake
/dev/dsp: No such file or directory
Now I know why there is no /dev/dsp device file anymore, but my question is simply, what do I have to do to get OSS emulation working? As I mentioned, I have the alsa-oss packages installed.

Code: Select all

[tja@area51m ~]$ rpm -qa | grep alsa-oss
I am not sure if I am missing any, these are the only ones I found. However, even with these packages, I am sure I still need some sort of device file, /dev/dsp, to at least act as a dummy for the program.

Can anyone help me out here?


Posted: Thu Aug 05, 2010 23:07
by tja1618
Ok, I need to eat some of my own words.

When using padsp with UT, I do get sound. However, I still get one error (not sure how important).

Code: Select all

/dev/mixer: Input/output error
Yet, with Quake 1, still no sound.

Posted: Fri Aug 06, 2010 17:36
by kratz00
UT and Q1 are both old and both use OSS.

I see you did install Alsa-Oss but is it actually loaded?

Run 'lsmod' and look for something like this:

snd_pcm_oss 33081 0
snd_mixer_oss 11814 1 snd_pcm_oss

I don't need padsp to get sound.

Posted: Sun Aug 08, 2010 22:03
by tja1618
Thanks for the reply!

Well, at first that wasn't loaded, but I loaded it and also uncommented the line in /etc/modprobe.d/dist-oss.conf

Code: Select all

# OSS Sound Support
# This has been disabled in F11 onwards because it can interfere with the
# PulseAudio sound service (a legacy OSS application can prevent PulseAudio
# applications from playing sound by preventing PulseAudio from (re-)opening
# the sound device). To re-enable support, uncomment the following line:
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss
Now, instead of /dev/dsp missing error I get a broke pipe:

Code: Select all

[tja@area51m ~]$ equake
/dev/dsp: Broken pipe
And still no sound...for some reason Quake 2 + 3 have sound, but Quake 1 and Doom 3 are giving me issues...

Code: Select all

[tja@area51m ~]$ lsmod | grep oss
snd_seq_oss            24950  0 
snd_seq_midi_event      4738  1 snd_seq_oss
snd_seq                41363  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          4867  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            33320  0 
snd_mixer_oss          11613  1 snd_pcm_oss
snd_pcm                59444  4 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pcm_oss
snd                    45127  11 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
[tja@area51m ~]$ 

Posted: Mon Aug 09, 2010 10:24
by kratz00
Doom 3 can make use of OSS or ALSA, please check what sound API your setup uses.

I'm not sure and I can't check it right now, but if the equake binary is (fuhquake-gl.glx), this should work arround the "broken pipe" problem:

fuhquake-gl.glx 0 0 direct > /proc/asound/card0/pcm0p/oss

If the binary is named differentchange it in the command above.

Posted: Mon Aug 09, 2010 19:36
by tja1618
Haha, i was just going to post that I figured that out. It works!

However, I am quite curious why I need this? But at least I can play Quake with audio now.

Thanks a lot for the help!

Posted: Mon Aug 09, 2010 20:19
by kratz00
Could you please summarize what you did exactly, do make each game work properly with sound.
This could help others with the same problem.


Posted: Sat Aug 14, 2010 1:19
by tja1618
Well, it has been easier now that I've struggled for so long but here it is....

First of all, you need the alsa-oss packages

Code: Select all

[tja@tja-fedora13 ~]$ rpm -qa |grep alsa-oss
Then you need to run the following command:

Code: Select all

echo "fuhquake-gl.glx 0 0 direct" > /proc/asound/card0/pcm0p/oss 
However, if after installing the packages you get an error about not having the oss file in the previous command, insert the module.

Code: Select all

[root@tja-fedora13 tja]# modprobe snd-pcm-oss
Now I got sound in equake! Hopefully someone finds this thread helpful!

EDIT: I never needed to uncomment the line in /etc/modprobe.d/dist-oss.conf.

Posted: Sat Aug 14, 2010 9:13
by kratz00
Thank you very much tja1618.