[Beta] SiN

Installers we are searching testers for.
kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

[Beta] SiN

Postby kratz00 » Fri Mar 16, 2012 19:51


doctoren
liflg beta tester
Posts: 27
Joined: Sat May 07, 2011 11:04

Re: [Beta] SiN

Postby doctoren » Mon Mar 19, 2012 9:28

I'll try it out asap. I remember getting a segfault with the previous installer on x86_32. What has changed in this one?

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: [Beta] SiN

Postby kratz00 » Mon Mar 19, 2012 21:19

I don't know. rettichschnidi did it, maybe he knows :D

doctoren
liflg beta tester
Posts: 27
Joined: Sat May 07, 2011 11:04

Re: [Beta] SiN

Postby doctoren » Mon Mar 19, 2012 21:41

Short story. It segfaulted on pre-release Ubuntu 11.04 x86_64. System is Intel Atom Dual-Core and a nVidia Geforce 9400.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: [Beta] SiN

Postby kratz00 » Mon Mar 19, 2012 22:56

Are you talking about the game or the installer itself?

Can you post the output?

doctoren
liflg beta tester
Posts: 27
Joined: Sat May 07, 2011 11:04

Re: [Beta] SiN

Postby doctoren » Tue Mar 20, 2012 0:37

The installer works. Only thing is that it wouldn't accept my serial number. The first time it quit after three tries but on second install I got it to work. I'm 100% sure that my serial input was correct so perhaps some of the other fields caused it.

The first time I ran sin.exe.sh it asked to override a couple of files/folders and wanted me to re-enter registration information.

The game segfault after outputting execing autoexec.cfg.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: [Beta] SiN

Postby kratz00 » Tue Mar 20, 2012 19:07

It would have been nice if you would have just posted the console output.

doctoren
liflg beta tester
Posts: 27
Joined: Sat May 07, 2011 11:04

Re: [Beta] SiN

Postby doctoren » Tue Mar 20, 2012 19:16

I know but it really isn't saying much. I see if I can test on another system. I think it was the same system that segfaulted on 32-bit the last time.

Code: Select all

OSS not available or usage of padsp requested!
Trying to find padsp
Found padsp, will use it!
Added packfile ./base/pak0.sin (9421 files)
Added packfile ./base/pak1.sin (289 files)
Added packfile ./base/pak2.sin (2978 files)
Added packfile ./base/pak3.sin (172 files)
execing default.cfg
couldn't exec /home/doc/.hyperion/Sin/players/blade/config.cfg
cddir is write protected.
NET Initialized
Console initialized.
------- Loading ./ref_soft.so -------
setting mode 3: 640 480 FS
Shutting down SW imp
Using DGA DirectMouse
1976k surface cache
ref_soft version: SOFT 0.01
------------------------------------

------- sound initialization -------
Sound device does not support mmap
sound sampling rate: 22050
------------------------------------
CD Audio Initialized
Mouse support enabled
execing autoexec.cfg
Segmentation fault (core dumped)

vblei
Posts: 4
Joined: Fri Mar 23, 2012 17:42

Re: [Beta] SiN

Postby vblei » Fri Mar 23, 2012 18:14

Game works after adding Loki_Compat into sin dir.

Hereby a execution of sin.exe.sh on Mandriva 2010.2 (Laptop)

Have aded Loki_Compat from http://www.swanson.ukfsn.org/loki/ (7 feb 2012)

Code: Select all

bash -x sin.exe.sh
+ GAME_BINARY=sin.exe
+ SUBDIR=.
+ LIBDIR=lib/
+ CMD_ARGS=
+ LOKICOMPATDIR=Loki_Compat
+ USE_PADSP=false
+ TRY_FALLBACK_TO_PADSP=true
+ export LANG=POSIX
+ LANG=POSIX
+ test -n ''
+ trap setxkbmap EXIT
+ trap resetgamma EXIT
+ SCRIPT=sin.exe.sh
++ dirname sin.exe.sh
+ SCRIPTDIR=.
+ COUNT=0
+ '[' -L sin.exe.sh ']'
++ dirname sin.exe.sh
+ GAMEDIR=.
+ '[' '' = true ']'
+ '[' -n '' ']'
+ '[' x. '!=' x. ']'
+ cd .
+ cd .
+ test -n lib/
+ export LD_LIBRARY_PATH=:lib/
+ LD_LIBRARY_PATH=:lib/
+ '[' '' = true ']'
+ '[' '' = true ']'
+ '[' true = true -o false = true ']'
+ handleoss
+ '[' '!' -c /dev/dsp -o false = true ']'
+ '[' '' = true ']'
++ md5sum sin.exe
++ awk '{print $1}'
+ '[' -f ref_gl.so.gz -o -f ref_soft.so.gz -o -f sin.exe.gz -o -f base/game.so.gz -o '!' -f sin.exe -o '!' -r sin.exe -o '!' -x sin.exe -o x0083aa7d3563eae2d6188808d7beb100 = xff3f64a7c8fd5d64439a87bcb5c703a7 ']'
+ '[' -d Loki_Compat ']'
+ echo 'Running game with Loki-Compat libraries.'
Running game with Loki-Compat libraries.
+ '[' false = true ']'
+ LD_LIBRARY_PATH=Loki_Compat
+ Loki_Compat/ld-linux.so.2 ./sin.exe
Added packfile ./base/pak0.sin (9421 files)
Added packfile ./base/pak1.sin (289 files)
Added packfile ./base/pak2.sin (2978 files)
Added packfile ./base/pak3.sin (172 files)
execing default.cfg
execing /home/johan/.hyperion/Sin/players/blade/config.cfg
Unknown command "rem"
cddir is write protected.
NET Initialized
Console initialized.
------- Loading ./ref_gl.so -------
ref_gl version: GL 0.01
SetMode: 0x0, mode=6, fullscreen=1
Using DGA DirectMouse
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 8600M GS/PCI/SSE2
GL_VERSION: 1.2 (2.1.2 NVIDIA 260.19.36)
GL_EXTENSIONS:   
...allowing CDS
...GL_EXT_compiled_vertex_array not found
...ignoring GL_EXT_point_parameters
...ignoring GL_ARB_multitexture
------------------------------------

------- sound initialization -------
Could not mmap sound device
Mouse support enabled
execing autoexec.cfg
------- Server Initialization -------
-------------------------------------
====== Sin Initialized ======

loopback: client_connect
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so

------- sound initialization -------
Cmd_AddCommand: music already defined
Cmd_AddCommand: soundtrack already defined
Cmd_AddCommand: play already defined
Cmd_AddCommand: stopsound already defined
Cmd_AddCommand: soundlist already defined
Cmd_AddCommand: soundinfo already defined
Could not mmap sound device

------- sound initialization -------
Cmd_AddCommand: music already defined
Cmd_AddCommand: soundtrack already defined
Cmd_AddCommand: play already defined
Cmd_AddCommand: stopsound already defined
Cmd_AddCommand: soundlist already defined
Cmd_AddCommand: soundinfo already defined
Could not mmap sound device
------- Loading ./ref_gl.so -------
ref_gl version: GL 0.01
SetMode: 0x0, mode=6, fullscreen=1
Using DGA DirectMouse
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 8600M GS/PCI/SSE2
GL_VERSION: 1.2 (2.1.2 NVIDIA 260.19.36)
GL_EXTENSIONS:   
...allowing CDS
...GL_EXT_compiled_vertex_array not found
...ignoring GL_EXT_point_parameters
...ignoring GL_ARB_multitexture
------------------------------------
execing default.cfg
execing /home/johan/.hyperion/Sin/players/blade/config.cfg
------- Loading ./ref_gl.so -------
ref_gl version: GL 0.01
SetMode: 0x0, mode=6, fullscreen=1
Using DGA DirectMouse
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 8600M GS/PCI/SSE2
GL_VERSION: 1.2 (2.1.2 NVIDIA 260.19.36)Loki_Compat
GL_EXTENSIONS:   
...allowing CDS
...GL_EXT_compiled_vertex_array not found
...ignoring GL_EXT_point_parameters
...ignoring GL_ARB_multitexture
------------------------------------

------- sound initialization -------
Cmd_AddCommand: music already defined
Cmd_AddCommand: soundtrack already defined
Cmd_AddCommand: play already defined
Cmd_AddCommand: stopsound already defined
Cmd_AddCommand: soundlist already defined
Cmd_AddCommand: soundinfo already defined
Could not mmap sound device
recursive shutdown
+ EXITCODE=0
+ '[' '' = true ']'
+ exit 0
+ resetgamma
+ '[' -n '' ']'


Have to look for in game sound, see error:

Code: Select all

ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so


Maybe configuring without pulse, will look at it.

Johan

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: [Beta] SiN

Postby rettichschnidi » Sun Mar 25, 2012 3:19

FYI: Just installed Ubuntu on my machine. I'll have a look at this.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: [Beta] SiN

Postby kratz00 » Sun Mar 25, 2012 18:24

I also had problems running SiN.
It crashed, like it did for doctoren.

doctoren please test this:
    change into the installation directory of SiN
    ./sin.exe.sh +set vid_ref gl

It seems it's trying to run the game with the software renderer by default on my setup.
Using the command switch the game is forced to use the hardware renderer.

vblei
Posts: 4
Joined: Fri Mar 23, 2012 17:42

Re: [Beta] SiN

Postby vblei » Mon Mar 26, 2012 21:51

vblei wrote:
Have to look for in game sound, see error:

Code: Select all

ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so


Maybe configuring without pulse, will look at it.


Have installed pulseaudio-utils and set padsp to true in sin.exe.sh, there is ingame sound.

But it is sometimes a bit later then an action and sounds sometimes like a robot (don't know how to say it in english, in dutch --> blikkerig geluid). google translate --> tinny sound.

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: [Beta] SiN

Postby rettichschnidi » Tue Mar 27, 2012 0:41

rettichschnidi wrote:FYI: Just installed Ubuntu on my machine. I'll have a look at this.


FYI2: Still struggling with the new multiarch thing...

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: [Beta] SiN

Postby rettichschnidi » Thu Mar 29, 2012 1:04

I just got the game up and running on Ubuntu 12.04, amd64, Intel graphics. The initial error was:

Code: Select all

ref_gl::R_Init() - could not load "opengl32"

I fixed it by linking libGL.so.1 to libGL.so (within the sin directory).

Code: Select all

ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 libGL.so


it's not a nice solution at all, hope we can find a better fix for this.

With loki compat the game crashes:

Code: Select all

loopback: client_connect
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
/media/cdrom/base/movies/sintro.mpg: No available audio device
Segmentation fault (core dumped)


So we do not have an universally working solution. :/

@doctoren: I'll try to get my shitty-nvidia-optimus-thing up and running. Hopefully I can reproduce your error afterwards.

doctoren
liflg beta tester
Posts: 27
Joined: Sat May 07, 2011 11:04

Re: [Beta] SiN

Postby doctoren » Thu Mar 29, 2012 9:31

Hi,
Sorry, my spare time is a bit filled up at the moment so I haven't done more testing. Also I would like to set up some more systems so I have a broader range of hardware to test on but alas I don't know when I'll get around to set it up.
Anyway, thanks for the effort so far and good luck with Optimus. I almost bought a netbook with it once but held off when I found out that it didn't work in Linux.


Who is online

Users browsing this forum: No registered users and 1 guest