UT2004 Midway DVD installer

Installers we are searching testers for.
pktm

Postby pktm » Wed Apr 16, 2008 15:36

Seems that there was a database backup.
So, yes, it worked well!

While I had some troubles with a patch, I encountered errors like this one (with the OS architecture detection) during uninstall. So, if the uninstaller is part of this installer, and anyone is going to fix it, this anyone shouldhave a look at the uninstaller, too.

Thanks a lot, pktm

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Wed Apr 16, 2008 17:07

What patch did you use and could you be more specific what problems did you encounter with the uninstaller?

pktm

Postby pktm » Thu Apr 17, 2008 17:29

Well, it seems I downloaded a patch for a 32bit version...
And, as there was no installer checking version and such things, I simply copied the folders which were included in the patch to the install dir and completely destroyed my installation. Even the uninstaller won't work.
Then I thought deleting anything and reinstalling it would be fine, but it wasn't, as the loki-installer remembers, what he has installed, and wouldn't install the game again (even if i deleted the ~/ut2004 folder).
So I recovered anything from trash and searched google for the location of the uninstaller.
Browsing to the installer, I tried it manually:

Code: Select all

> cd ~/.loki/installed/bin/Linux/x86_64
> ./uninstall my_parameters....


That wasnessecary, as the uninstall-script in the ut2004 directory didn't execute (i think I remeber it saying something about a file he could not found, and I bet it was the x86_64 dir (because searching for amd64).

But I have to admit, that I didn't examine it any further, as the game was running after uninstalling the corrupted files and a fresh install.

I downloaded the patch from a link at the holarse/ut2004 page (should be this one, host isn't reachable atm: http://www.holarse-linuxgaming.de/h2006 ... ament+2004 ). It was the magepack thing.

HTH, pktm

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Thu Apr 17, 2008 19:01

Strange but why didn't you use our update installer?

ut2004.megapack-english-3.run

http://liflg.org/?catid=6&gameid=17

pktm

Postby pktm » Thu Apr 17, 2008 21:31

kratz00 wrote:Strange but why didn't you use our update installer?

ut2004.megapack-english-3.run

http://liflg.org/?catid=6&gameid=17


Oh cool. I didn't know that there was something like that.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Mon Apr 28, 2008 22:33

No problem :)

By the way I have fixed the installers.

nazgul

works like a charm on Ubuntu 8.10/x86_64

Postby nazgul » Wed Apr 01, 2009 20:57

Vielen Dank, Installer läuft einwandfrei!

ut2004_3369-german.midway.dvd-6.run

Der Eintrag ins Programmenü geht allerdings nach Anwendungen->Sonstige und nicht nach Spiele.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Sat Apr 25, 2009 15:51

Thanks but we know already, lots of the older installers have this glitch.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Sun Jul 26, 2009 11:32



Who is online

Users browsing this forum: No registered users and 1 guest