Serious Sam 2 installer

Installers we are searching testers for.

jtravnick

Postby jtravnick » Mon Dec 10, 2007 19:39

tried running the CD version and get the following when it starts:

[jim@localhost ~]$ sudo sh serious.sam2_2.070beta2.1-multilanguage.4cd.run
Password:
Verifying archive integrity... All good.
Uncompressing Serious Sam 2 2.070beta2.1-multilanguage.dvd Installer..

Also this installer will not believe that the CD is in the drive I can press the yes till my finger falls off and it will go no farther.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Tue Dec 11, 2007 21:32

The output is wrong, you are right but this dosen't matter.
Did you read our FAQ's?

export SETUP_CDROM ...

if this dosen't help mount the first disc and show me the output of "ls -lR"

wusch

Postby wusch » Thu Dec 20, 2007 21:56

Hello!

I've got the same problem here, although I use the DVD-version of SS2 (+ DVD-installer). The 'export SETUP_CDROM=/dev/cdrom0'-command won't help - maybe it's because of that I'm using Xubuntu Feisty, which mounts everything to /media/... by default?

ls -IR /media/cdrom
AutoRun.exe AutoRun.inf Disk2 Disk4 Handbuch
AutoRun.ico Disk1 Disk3 Disk5 Setup.exe

Btw., 'cdrom is symlinked to cdrom0' by ubuntu. I've experimented a little and re-mounted 'hdc' to /media/dvd and also used 'export SETUP_DVD' analog to this, or '_CDROM0' - no workie...

I have tried using the official 'linuxbeta' from croteam, but it doesn't seem to install properly; funny thing: it will run the game, but with crippled sound and when starting a level, the game crashes.

EDIT - output after running the 'official linuxbeta':

I tried to run the program; at first, it starts (with crackling sound) but on starting a level, I get follwing error-message:


INF:
INF: Gfx API: OpenGL
INF: Window: 640 x 480
INF: Vendor: ATI Technologies Inc.
INF: Renderer: Radeon X1950 Series
INF: Version: 2.0.6334 (8.34.8)
INF:
INF: Sfx API: OpenAL
INF: Device: (unknown)
INF: Mixer freq: 44100 Hz
INF: HW voices: 32
INF: Max sounds: 25 (5 same)
INF: Env FX: not supported
INF:
WRN: Couldn't compile GPU program!
WRN: Error occured during thread priority setting. (Errorcode 1)
WRN: Couldn't compile GPU program!
INF:
INF: Current settings:
INF:
INF: Max texture size: 1024 x 1024
INF: Texture quality: optimal
INF: Texture filtering: Trilinear (22)
INF: Anisotropy degree: none (isotropic filtering)
INF: Mipmap LOD bias: none
INF: Anti-aliasing: none
INF: Flat reflect only: no
INF: Refraction mip: 0
INF: Max pix-prog ver: 3.0
INF: Force pix-prog 2: no
INF:
INF: Performace testing results:
INF:
INF: -> Vertex thruput (abs,rel):
INF: simple: 195.88 (Mvtx/s), 156.7%
INF: complex: 85.49 (Mvtx/s), 244.3%
INF: -> Pixel thruput (abs,rel):
INF: triple texture: 1390.29 (Mpix/s), 173.8%
INF: bump specular: 921.39 (Mpix/s), 139.6%
INF: bump reflection: 1032.68 (Mpix/s), 286.9%
INF: bump refraction: 118.73 (Mpix/s), 24.7%
INF: multi texture: 3263.45 (Mpix/s), 1087.8%
INF:
INF: = 3.29x faster than GeForce 6600-GT (128MB)
WRN: Couldn't compile GPU program!
INF:
INF: Gfx API: OpenGL
INF: Resolution: 1024 x 768
INF: Vendor: ATI Technologies Inc.
INF: Renderer: Radeon X1950 Series
INF: Version: 2.0.6334 (8.34.8)
WRN: Couldn't compile GPU program!
INF: Simulationsstart auf 'Content/SeriousSam2/Levels/01_Mdigbo/1_1_Jungle/1_1_Jungle.wld' in 24.85 Sekunden.
Segmentation fault (core dumped)



perixx[/quote]

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Sat Dec 22, 2007 13:15

Hi wush

i should be

export SETUP_CDROM=/media/cdrom

not the device, the mountpoint is important :)
and do not change the variable its always the same for every type of media (cd, dvd ,,,)

our installer includes the official beta

wusch

Postby wusch » Sun Dec 23, 2007 0:59

Hi kratz00!

Thanks for replying...
The command you named shows no effect! I believe I tried it the same way before, but...
Anyway, Thunar (Xubuntu's filemanager) shows my DVD mounted as 'SERIOUSSAM2' on cdrom0.

What is wrong?

perixx

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Mon Dec 24, 2007 14:44

replace $X with your mountpoint

export SETUP_CDROM=$X

man mount :)

wusch

Postby wusch » Tue Dec 25, 2007 21:08

I'm afraid you've got to be a little more specific... what mountpoint do you mean in my case?

/etc/fstab shows
'
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0

So I would interprete this as the mount-point of the DVD being 'media/cdrom0', correct?
'Cdrom1' is the second CD-drive.

Thunar filemanager shows 'SERIOUSSAM2' in the tree-view being in the DVD-drive.

I've opened a terminal in the folder containing the '.gro' files (~/ss2) and, being there, entered

Code: Select all

export SETUP_CDROM=/media/cdrom0

which should be the appropriate 'export'-command, isn't it?

I've also tried

Code: Select all

SETUP_CDROM=/media/cdrom1
SETUP_CDROM=/media/cdrom
SETUP_CDROM=$/media/cdrom0


When I run the installer, I can try to proceed with 'begin install' or change the installation folder first - the outcome will be the same, an error message:
Please mount Serious Sam 2 DVD.
Choose Yes to retry, No to cancel


Having no success, I attempted the following:

Code: Select all

sudo umount /media/cdrom0
sudo mount -t iso9660 /dev/hdc /mnt/cdrom0
mount: block device /dev/hdc is write-protected, mounting read-only
export SETUP_CDROM=$/mnt/cdrom0

because I figured, the installer might dislike '/media/cdrom0' as mount-point and prefer a standard-Linux' one.

Unless I'm doing it wrong (I can't figure how, though), the installer doesn't seem to function in my setup...

wusch

wusch

Postby wusch » Wed Dec 26, 2007 3:38

Btw., I possess the software-pyramid-version DVD from '2k' of SS2 (German)...

wusch
Last edited by wusch on Wed Dec 26, 2007 18:31, edited 1 time in total.

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Wed Dec 26, 2007 10:46

<code>
export SETUP_CDROM=/media/cdrom0
</code>

looks good, maybe the layout of your dvd differs, please post the output of "ls -R" of the mounted disc.

wusch

Postby wusch » Wed Dec 26, 2007 18:30

here it is:

cdrom0$ ls -R /media/cdrom0
/media/cdrom0:
AutoRun.exe AutoRun.inf Disk2 Disk4 Handbuch
AutoRun.ico Disk1 Disk3 Disk5 Setup.exe

/media/cdrom0/Disk1:
Bin Content_PC_FRA.gro Patch_02_068_Content_ITL.gro
Content Content_RUS.gro Patch_02_068_Content_PC_FRA.gro
Content_DEU.gro Disk1.txt Patch_02_068_Content_RUS.gro
Content_ITL.gro Patch_02_068_Content_DEU.gro Patch_02_068.gro

/media/cdrom0/Disk1/Bin:
CodecOGG.dll DedicatedServer.exe msvcp71.dll Sam2Game.dll
Core.dll Engine.dll msvcr71.dll SfxDSD.dll
d3dx9_25.dll GfxD3D.dll OnlineGS.dll SfxOAL.dll
d3dx9_26.dll GfxOGL.dll ProcRender.dll Shaders.dll
d3dx9_27.dll GPU-Programs.asm Sam2.exe

/media/cdrom0/Disk1/Content:
Installer SeriousSam2

/media/cdrom0/Disk1/Content/Installer:
ArcadeInstall.exe DirectX9.0c gamespy.ico xfire_installer.exe

/media/cdrom0/Disk1/Content/Installer/DirectX9.0c:
BDANT.cab BDAXP.cab dsetup32.dll DSETUP.dll dxnt.cab dxsetup.exe

/media/cdrom0/Disk1/Content/SeriousSam2:
Config DedicatedServer_RUS.html ReadMe_ENG.html
DedicatedServer_DEU.html Demos ReadMe_ENU.html
DedicatedServer_ENG.html DMMapList.txt ReadMe_FRA.html
DedicatedServer_ENU.html Menus ReadMe_ITL.html
DedicatedServer_FRA.html Models ReadMe_RUS.html
DedicatedServer_ITL.html ReadMe_DEU.html

/media/cdrom0/Disk1/Content/SeriousSam2/Config:
SafeMode.cfg user.cfg

/media/cdrom0/Disk1/Content/SeriousSam2/Demos:
Demo_0001.dem Demo_0002.dem Demo_0003.dem
Demo_0001.nfo Demo_0002.nfo Demo_0003.nfo

/media/cdrom0/Disk1/Content/SeriousSam2/Menus:
CMSAdvancedOptions.rsc CMSItemSettings.rsc
CMSAdvancedVideoOptions.rsc CMSMultiplayer.rsc
CMSAudioOptions.rsc CMSOptiMatchDetails.rsc
CMSCallAVote.rsc CMSOptiMatchList.rsc
CMSChangeName.rsc CMSPowerupSettings.rsc
CMSCooperativeSettings.rsc CMSServerList.rsc
CMSCreateNewProfile.rsc CMSVotingSettings.rsc
CMSCustomizeKeys.rsc CMSWeaponSettings.rsc
CMSDeathmatchSettings.rsc CPopupMenuEnterTextLarge.rsc
CMSGamespy.rsc CPopupMenuEnterText.rsc

/media/cdrom0/Disk1/Content/SeriousSam2/Models:
Player

/media/cdrom0/Disk1/Content/SeriousSam2/Models/Player:
GroovyGregory.dsc GroovyGregory.nfo

/media/cdrom0/Disk2:
All_PC_03.gro Disk2.txt

/media/cdrom0/Disk3:
All_PC_02.gro Disk3.txt

/media/cdrom0/Disk4:
All_PC_01.gro Disk4.txt Movies_PC_02.gro

/media/cdrom0/Disk5:
Disk5.txt Movies_PC_01.gro

/media/cdrom0/Handbuch:
Acrobat Handbuch

/media/cdrom0/Handbuch/Acrobat:
AdbeRdr707_German.exe

/media/cdrom0/Handbuch/Handbuch:
Handbuch.pdf

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Sat Dec 29, 2007 14:49

Your dvd layout is completely different, also your version is already patched. Could you find out what version this is and when i will be fine soon i'm going to build an installer for this version.

wusch

Postby wusch » Sun Dec 30, 2007 2:30

hello kratz00!

What version do you mean? The game's patch-version (seemingly 02-68, from what the CD-content suggests) or the game-version itself?

If it's the latter, don't know how to check this... maybe when entering the console/cheat mode??

wusch

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Sun Dec 30, 2007 10:48

I thought of "Game of the Year" or something like this.

I had a look on my dvd and it has disk1 till disk4 and yours disk1 till disk5 subdirectories and also there is no "Handbuch" subdirectory on my dvd.

wusch

Postby wusch » Sun Dec 30, 2007 17:23

oh well, 'Handbuch' means just 'manual'...
I was looking at the envelope of the DVD - there's nothing entitled like you've mentioned. The publisher is '2k', that's the only logo on the DVD-cover (apart from Serious Sam II, of course). The game was a 10€ bargain from the 'software pyramid', with a simple carton-box, containing the DVD-cover.

Btw., there's a version-number shown at the menu-screen:
v.2.068.00: 62878

-- I hope this is of any use to you!

I've read several times about this special DVD-release for the German market being a major annoyance regarding the incompatibility problems with the latest 2.070 patch and because of the #&$@! copy protection (I believe Starforce) -- in a 10€-version (!!!).
Erm, before I forget it, there's also this annoying 'GameSpy' coming with this version.

Just an idea, but, maybe the files don't differ so much from your version (apart from different language versions perhaps) and are just distributed differently;
I've seen 'Movies_PC_01.gro' and Movies_PC_02.gro' plus 'All_PC_01.gro' to 'All_PC_03.gro' - if I'm not mistaken, the only relevant files for the linux-installer?

There's also the 'Patch_02_068.gro' and the translation '.gro'-files...
Me personally, I don't care for the German translation, because it sucks anyway and I can do without for instance - others might think differently, of course.

Also the quality of the video sequences is really bad... but that's another story.
I hope you can make something of this info here...
thank you very much for paying attention to this additional version!

best regards

wusch


Who is online

Users browsing this forum: No registered users and 1 guest