Updated Installers for Loki-Software Games

Installers we are searching testers for.
rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Sat Feb 19, 2011 16:07

Wow, my bad. In fact I created an updated installer, but it's not yet on the download page, sorry. Will fix that ASAP.

eriktorbjorn
Posts: 7
Joined: Tue May 18, 2010 21:04

Re: Updated Installers for Loki-Software Games

Postby eriktorbjorn » Sun Feb 20, 2011 0:58

rettichschnidi wrote:Wow, my bad. In fact I created an updated installer, but it's not yet on the download page, sorry. Will fix that ASAP.


Thanks! It seems to be working now. As well as could be expected, anyway.

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Sun Feb 20, 2011 8:22

eriktorbjorn wrote:As well as could be expected, anyway.


Does this mean that it works good or bad?

@rest: We have updated our Heavy Gear II installer by now.

eriktorbjorn
Posts: 7
Joined: Tue May 18, 2010 21:04

Re: Updated Installers for Loki-Software Games

Postby eriktorbjorn » Sun Feb 20, 2011 9:25

rettichschnidi wrote:Does this mean that it works good or bad?


Well, the game seems to run well, but there are some minor problems that I wouldn't expect the installer to fix.

The ground is covered by a black grid that wasn't there on my old computer and the Matrox G400 DRI driver. Nowadays I'm using the open r300 driver. I thought perhaps the new Gallium3D driver would behave differently than the old DRI driver, but in this respect it doesn't. I don't know if it's the driver or the graphics engine that does something wrong.

It's a bit hard to use the sniper mode because it zips between fully zoomed in and fully zoomed out so quickly, but that's probably because the game didn't expect computers to be this fast.

And once I've let the 3D engine run, it segfaults on exit which I suppose is a good place for it to do so if it absolutely has to. I was able to attach GDB to the running process and get a backtrace, but it didn't make much sense to me:

Code: Select all

Program received signal SIGSEGV, Segmentation fault.
0xb7510a14 in getenv (name=0xb76c6294 "TALLOC_FREE_FILL") at getenv.c:84
84      getenv.c: No such file or directory.
        in getenv.c
(gdb) bt
#0  0xb7510a14 in getenv (name=0xb76c6294 "TALLOC_FREE_FILL") at getenv.c:84
#1  0xb76c09c2 in _talloc_free () from /usr/lib/libtalloc.so.2
#2  0xb76c4bfa in ?? () from /usr/lib/libtalloc.so.2
#3  0x080556e5 in __cxa_finalize ()
#4  0xb76bfa94 in ?? () from /usr/lib/libtalloc.so.2
#5  0xb76c6100 in ?? () from /usr/lib/libtalloc.so.2
#6  0xb77bd226 in _dl_fini () at dl-fini.c:248
#7  0xb75112bf in __run_exit_handlers (status=0, listp=0xb7624304,
    run_list_atexit=true) at exit.c:78
#8  0xb751132f in exit (status=0) at exit.c:100
#9  0xb74f8c7e in __libc_start_main (main=0x8051b00 <main>, argc=3,
    ubp_av=0xbfde03f4, init=0x8050c7c <_init>, fini=0x8080b3c <_fini>,
    rtld_fini=0xb77bd040 <_dl_fini>, stack_end=0xbfde03ec) at libc-start.c:260
#10 0x08051551 in _start ()


But as I said, I wouldn't expect an installer to fix these things. Except maybe the last one, but that depends on what the real cause of the crash is and I have no idea.

Hamish
Posts: 16
Joined: Sat May 22, 2010 9:47

Re: Updated Installers for Loki-Software Games

Postby Hamish » Mon Feb 21, 2011 20:39

I had the urge to play Soldier of Fortune again recently, but after installing it I ran into the OpenGL string error. I never encountered it before as I had always previously played it on a system using the free software drivers, but in this instance I was installing it on my Fedora 14 box with Catalyst which has more GL extensions. It seems like kind of an odd bug, I wonder if the Windows version is similarly affected?

Your installer fixed the problem, and also installed the Gold version for me which was newer than what I was playing with before. I just reached the first Siberian level and have so far encountered no problems. What do you have left before you can declare the installer as stable? Are there still any problems I have not encountered yet?
Hamish Paul Wilson, VA6GNU

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Tue Feb 22, 2011 1:06

Hamish wrote:What do you have left before you can declare the installer as stable?

We just let them be in beta till we think that we got enough positive feedback - guess we could declare easily some of our beta installer as final by now.

Hamish wrote:Are there still any problems I have not encountered yet?


Not as far as we know.

I hope we manage to move them to the final section within the next weeks, but don't hold your breath!

ckblackm
liflg beta tester
Posts: 2
Joined: Sun Oct 31, 2010 4:04

Re: Updated Installers for Loki-Software Games

Postby ckblackm » Tue Feb 22, 2011 2:01

Any progress on the English version of Civilization: Call to Power?

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Tue Feb 22, 2011 9:37

Since you asked already twice: I'll start today. :)

Sounds good?

march
liflg beta tester
Posts: 22
Joined: Mon Jun 22, 2009 21:57
Contact:

Re:

Postby march » Thu Mar 24, 2011 21:00

Successfully tested on Ubuntu 10.04 (64bit):
  • Robin Hood (german)
  • SC3U
  • Heavy Metal: F.A.K.K.2
  • Heavy Gear II
  • Kohan: Immortal Sovereigns
  • Myth II: Soulblighter + Addon
  • Railroad Tycoon II (german)
  • Civilization: Call to Power

Not working:
  • Eric's Ultimate Solitaire (error while loading shared libraries: libesd.so.0: cannot open shared object file: No such file or directory)

Errors while installing civ and fakk2:
/usr/lib/gio/modules/libgvfsdbus.so: falsche ELF-Klasse: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so


Cool would be installers for Darwinia and Terminus.


death-row.org is down. :( I downloaded these files a few months ago - so I could test these installers too. :wink:

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Sat Mar 26, 2011 11:25

Thanks a lot for testing.

@EUS: Please try this one: http://liflg.org/?catid=7&gameid=92

@Errors while installing civ and fakk2: Thats no problem at all, its just GTK whining about some missing but not really needed libraries.

@death-row.org: we know and we are working on a solution

march
liflg beta tester
Posts: 22
Joined: Mon Jun 22, 2009 21:57
Contact:

Re: Updated Installers for Loki-Software Games

Postby march » Sun Mar 27, 2011 1:21

rettichschnidi wrote:@EUS: Please try this one: ftp://files.reto-schneider.ch/liflg/201 ... 6.mojo.run

Done - this time it worked . The installer I used before was the first version I suppose.

march
liflg beta tester
Posts: 22
Joined: Mon Jun 22, 2009 21:57
Contact:

Re: Re:

Postby march » Mon Mar 28, 2011 23:34

Successfully tested on Ubuntu 10.04 (64bit):
  • Heretic II

The only problem: after quitting the game the resolution of my desktop was set wrong. Using 640x480 ... ;) Only happened once.

One minor thing: the files of the manual in help are missing.

Reve
Posts: 14
Joined: Wed Apr 05, 2006 15:41

FAKK2 cant find libGL.so

Postby Reve » Fri Apr 22, 2011 7:55

I try HeavyMetal FAKK2 installer. It works but the game dont start. It give massage that it cant find libGL.so.
For my it look similiar to heretic 2 libGL problem fixed in new installer. Can You fix that ?

I work on Fedora13 with Nvidia binary driver.

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Fri Apr 22, 2011 17:10

Please post the full error message and show me where your 32bit libGL.so is.

Reve
Posts: 14
Joined: Wed Apr 05, 2006 15:41

Re: Updated Installers for Loki-Software Games

Postby Reve » Tue Apr 26, 2011 19:56

OK It seems to by my fedora error.
Libelaries in /usr/lib was mesa ones probably from default driver (nouveau).
Corect libGL.so.1 from Nvidia binary driver was in /usr/lib/nvidia.
I have delate that in /usr/lib and copy from /usr/lib/nvidia and it worked,
but probably last OS update overwrite it back to mesa ones.


Who is online

Users browsing this forum: No registered users and 1 guest