Updated Installers for Loki-Software Games

Installers we are searching testers for.
march
liflg beta tester
Posts: 22
Joined: Mon Jun 22, 2009 21:57
Contact:

Re: Updated Installers for Loki-Software Games

Postby march » Sun May 29, 2011 11:05

These installers are working with Kubuntu 11.04:
  • airline tycoon deluxe
  • civilization: call to power
  • eric's ultimate solitaire
  • railroad tycoon II
  • heavy gear II
  • heavy metal: fakk2
  • heretic II
  • kohan: immortal sovereigns
  • machinarium (full)
  • myth II: soulblighter
  • railroad tycoon II
  • robin hood
  • simcity 3000

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Sun May 29, 2011 23:47

Thanks a lot.

doctoren
liflg beta tester
Posts: 27
Joined: Sat May 07, 2011 11:04

Re: Updated Installers for Loki-Software Games

Postby doctoren » Sun Jun 12, 2011 22:28

Just tested the SoF installer on Ubuntu 10.10 x86. As it is an OSS game there is no sound so the installer needs to include a fix for this. The rest is working fine.

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Mon Jun 13, 2011 4:48

Thanks. I just uploaded an updated installer for internal testing. Have fun testing it. :)

Treebase
Posts: 1
Joined: Mon Jun 13, 2011 23:00

Re: Updated Installers for Loki-Software Games

Postby Treebase » Tue Jun 14, 2011 0:34

Successfully installed and running Sid Meier's Alpha Centauri Planetary Pack from Loki Games using smac_6.0a-english_x86.mojo.run (currently available for download from beta installers). :D

Running Ubuntu 10.04 64 bit (my somewhat dated system)
uses onboard intel graphics

Installation experience:

Gameplay Experience:
sounds, video, gameplay worked on first try with some minor differences based on .sh used (see below)
native resolution 1680x1050, game runs (apparently) 1024x768
played several turns without crashes

Code: Select all

vick@steelHorse:~/smac$ ./smacpack.sh

successfully runs launcher
menu animates correctly
sounds and menu options work correctly on first try
utilizes widescreen appropriately

Code: Select all

vick@steelHorse:~/smac$ ./smac.sh

successfully runs alpha centauri
initial flicker, then video and gameplay uses widescreen appropriately
Sound worked on first try
on exit, does not return X to previous resolution (no big deal)

Code: Select all

vick@steelHorse:~/smac$ ./smacx.sh

successfully runs alpha centauri alien cross fire expansion
no problems with intro video, sounds, gameplay, all work on first try
exits gracefully

ultimately, an amazing job
thank you guys so much for all the hard work
I'm a complete novice to SMAC, but I'm glad to get a chance to learn it on Linux (natively!)

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Tue Jul 05, 2011 5:40

Thanks for the feedback.

randomas
Posts: 2
Joined: Sat Jan 07, 2012 14:17

Re: Updated Installers for Loki-Software Games

Postby randomas » Sat Jan 07, 2012 14:23

Does the Heavy Gear 2 installer also run with the windows cd of the game?

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Updated Installers for Loki-Software Games

Postby kratz00 » Sat Jan 07, 2012 15:06

Hi randomas,

no it does not. It requires the Linux version from Loki.


Regards
-Steffen

randomas
Posts: 2
Joined: Sat Jan 07, 2012 14:17

Re: Updated Installers for Loki-Software Games

Postby randomas » Mon Jan 09, 2012 1:54

Oh well thought so ... Pity ... I had even made a multiplayer map for the game at the time ... I wonder if anyone still plays it ...

Thanks for the info!

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Re: Updated Installers for Loki-Software Games

Postby kratz00 » Mon Jan 09, 2012 12:20

Hi randomas,

I can't answer that, but I doubt that a lot of people are still playing Heavy Gear 2 :D


Regards
-Steffen

motleyque
Posts: 6
Joined: Tue Apr 10, 2012 7:12

Re: Updated Installers for Loki-Software Games

Postby motleyque » Tue Apr 10, 2012 7:19

Hey there, I am a bit a noob to linux but I'll do the best I can.

First off, thanks to those that put these installers together, very nice work!

Now, I am having some problems with Alpha Centauri, I am running CrunchBang (a Debian distro) on an Inspiron N5010 with an Intel CPU.

The installation seems to run fine, until the final step, I'll show you what I have in the terminal:

Code: Select all

...smac: 2% (total progress: 96%)
smac.dynamic: 4% (total progress: 97%)
smacpack: 5% (total progress: 98%)
smacx: 2% (total progress: 98%)
smacx.dynamic: 3% (total progress: 99%)
Installing
Metadata
liflg_org-smac_1.desktop: 100% (total progress: 99%)
NOTICE: Failed to install desktop menu item
[hit enter]

Incomplete installation. We will revert any changes we made.

NOTICE: Couldn't restore some files. Your existing installation is likely damaged.
[hit enter]


Then, nothing works, not smacpack, not smac, and certainly not smacx. The problem is, I can see that the install was 99% successful!

rettichschnidi
liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Re: Updated Installers for Loki-Software Games

Postby rettichschnidi » Tue Apr 10, 2012 17:00

Please tell me if you are using the 32 or 64bit version. I'll test the installer ASAP on this distribution.

motleyque
Posts: 6
Joined: Tue Apr 10, 2012 7:12

Re: Updated Installers for Loki-Software Games

Postby motleyque » Tue Apr 10, 2012 19:04

sorry, 64-bit.

motleyque
Posts: 6
Joined: Tue Apr 10, 2012 7:12

Re: Updated Installers for Loki-Software Games

Postby motleyque » Fri Apr 13, 2012 22:59

Hello again,

I had another go at installing SMAC today, and by closing the terminal before the installer could "revert the changes" I managed to boot the game!

However, I then had these problems;

1)No sound
2)Once I loaded a world and entered the name of my first city, the game crashed and closed. I tried 2-3 times to no avail.

froseph
Posts: 2
Joined: Sat Apr 14, 2012 2:52

Re: Updated Installers for Loki-Software Games

Postby froseph » Sat Apr 14, 2012 5:51

Hey,

Thank you for your awesome smac installer. I spend many hours this past week hacking away at getting smac to run before I found your installer. A few questions.

1/ Does your patch add the 6.0b patch?
2/ The loki compat libs you ship are old- they have been updated to 1.5. I copied version 1.5 and didn't have any problems.

A few hints and suggestions for motleyque:
motleyque wrote:1)No sound
2)Once I loaded a world and entered the name of my first city, the game crashed and closed. I tried 2-3 times to no avail.

1/ For me, sdl libs didn't seem to work with alsa, or pulseaudio, when i tried editing SDL_AUDIODRIVER to "alsa", "esd", and "pulse". Maybe the sdl libs were not compiled with these enabled? I don't know. I gave up and installed the oss audio driver via "sudo modprobe snd_pcm_oss".

2/ I'm not sure that your installer completed. It sounds like you are running the staticly linked version of smac which shipped with the smac cd. You need to run smac(|x|pack).sh (as installed by the installer found here), or smac(x|pack).dynamic with the LD_LIBRARY_PATH set to the path of loki_compat. The *.dynamic executables are installed after you patch smac to 6.0b. Regardless, I believe this error is caused by the compsite extenions in Xorg. If you are dead set on continuing you can run smac in Xephyr, disable composite in X.org, or try disabling in compiz http://ubuntuforums.org/showthread.php?t=1206578. N.B. I only tried running it in Xephyr. Google should show you how to do this.


Who is online

Users browsing this forum: No registered users and 1 guest