Serious Sam TFE - Demos

Need help with one of the installers?
Arkem

Serious Sam TFE - Demos

Postby Arkem » Sat Jan 27, 2007 22:23

I have noticed that in TFE épisode of Serious Sam, the Demos refuses to launch for a stupid reason: The date and time of demo files are older than the levels data it uses !
The explanation is very simple: The installer copy the demo files BEFORE the levels data files, so, on some older systems like mine, the very tiny difference between files time makes the error occure.

I think about four solutions for this problem:
- The developement team (if it still exists) patches the game to use a more sinificant difference between files time.
- Modify the install script to copy the demo files AFTER the levels data files.
- Add the --preserve=timestamps parameter to the cp command in the install script.
- Add a line like this at the end of the install script to set demo files to a more recent time:
touch /usr/local/games/ssamtfe/Demos/*.dem

I used the last solution on my system with success. 'think it should work for everyone else... ;)

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Sun Jan 28, 2007 21:04

What are you talking about?

Arkem

Postby Arkem » Mon Jan 29, 2007 1:40

I know my english isn't very good, but I don't know exactly what you don't understand...

In other words, when I try to launch a demo (recorded sequence of gameplay) in SSamTFE, the game claims tha it is not possible because the demo file is older than the map file.
For example, if I try to launch auto-demo0001, the only thing I obtain is the following message:

Code: Select all

Cannot play demo: Cannot play demo because file 'Demos/auto-demo0001.dem' is older than file 'Levels/AlleyOfSphinxes.wld' !


I think game devs decided to create this error code to avoid launching old demo with newer version of the same map while developing the game...

The problem is that while installing the game, the files timestamp is updated to current time, and so, it is possible that a slow machine have a few seconds difference between the map files (Levels\*.wld) and the demo files (Demos\*.dem) that makes the error occure !

I solved the problem on my machine with the following command:

Code: Select all

touch /usr/local/games/ssamtfe/Demos/*.dem


I hope I was more understandable this time... :?

kratz00
liflg member
Posts: 1654
Joined: Fri Oct 22, 2004 16:23

Postby kratz00 » Mon Jan 29, 2007 11:08

sorry i thought you was talking of a (game)demo or a something like this, my fault :)

now i got it

The is no and there will no development happen to ssam anymore :( but we can change the installer.

Thanks for finding the problem and offering solutions.

Arkem

Postby Arkem » Mon Jan 29, 2007 17:06

'happy to make a little contribution ;)

kingron
liflg member
Posts: 158
Joined: Wed Nov 03, 2004 11:14

Postby kingron » Tue Feb 06, 2007 9:44

hi,

thanks again for your bug-report, i just updated the ssam installer

Changelog:

- Installer now with GTK2 support
- Installing the DEMO files after LEVEL files ;-)
- fixed bug with the "Technologie Test" in the ssamtse game
- removed orginal shipped libs:
libvorbis* (which prevent running the game on my machine, also i can change now solutions greater than 640x480 again)
libogg*

please make sure you have got installed these libs on your system, check the README.liflg

http://home.coc-ag.de/dressler-ro/liflg ... lish-2.run
http://home.coc-ag.de/dressler-ro/liflg ... lish-2.run

would be nice if you could check the installer and feedback is very welcome

thx
ron

Arkem

Postby Arkem » Tue Feb 06, 2007 16:04

I checked the new installers of SSamTFE and SSamTSE, and everything worked fine :)

Thanks


Who is online

Users browsing this forum: No registered users and 1 guest